summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Rohman2022-10-15 09:47:01 +0700
committerAli Rohman2022-10-15 09:47:01 +0700
commit3c3e91a96c912cebccd1c8393f2fea9fb81c3907 (patch)
treeddcf22eddd292648926a21ca8dd49add678a6668
downloadaur-3c3e91a96c912cebccd1c8393f2fea9fb81c3907.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD26
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..398cc3303d1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = hidamari
+ pkgdesc = Video wallpaper for Linux. Written in Python.
+ pkgver = 3.0.beta4
+ pkgrel = 1
+ url = https://github.com/jeffshee/hidamari
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = gtk-update-icon-cache
+ makedepends = desktop-file-utils
+ depends = python-gobject
+ depends = python-pillow
+ depends = python-pydbus
+ depends = python-vlc
+ depends = yt-dlp
+ depends = dconf
+ depends = python-requests
+ depends = gnome-desktop-4
+ optdepends = vdpauinfo: Query and display VDPAU capabilities
+ optdepends = libappindicator-gtk3: tray icon support
+ optdepends = webkit2gtk: web video support
+ source = git+https://github.com/jeffshee/hidamari.git#tag=v3.0-beta4
+ sha256sums = SKIP
+
+pkgname = hidamari
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c72ad16f84d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ali Rohman <laymoth@pm.me>
+
+pkgname=hidamari
+pkgver=3.0.beta4
+_pkgver=3.0-beta4
+pkgrel=1
+pkgdesc='Video wallpaper for Linux. Written in Python.'
+arch=('any')
+url='https://github.com/jeffshee/hidamari'
+license=('GPL3')
+depends=('python-gobject' 'python-pillow' 'python-pydbus' 'python-vlc' 'yt-dlp' 'dconf' 'python-requests' 'gnome-desktop-4')
+makedepends=('git' 'meson' 'gtk-update-icon-cache' 'desktop-file-utils')
+optdepends=('vdpauinfo: Query and display VDPAU capabilities'
+ 'libappindicator-gtk3: tray icon support'
+ 'webkit2gtk: web video support')
+source=("git+https://github.com/jeffshee/hidamari.git#tag=v${_pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ arch-meson "${pkgname}" build
+ meson compile -C build
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+} \ No newline at end of file