summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli2022-11-09 19:34:56 +0700
committerAli2022-11-09 19:34:56 +0700
commit3d086b5723c01840d60c005d3f2d49988fe6bbd2 (patch)
treea3a1fa496d066110d380e76a27e7ca1037d59af3
parent3c3e91a96c912cebccd1c8393f2fea9fb81c3907 (diff)
downloadaur-3d086b5723c01840d60c005d3f2d49988fe6bbd2.tar.gz
v3.1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 398cc3303d1e..8395a1a54995 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hidamari
pkgdesc = Video wallpaper for Linux. Written in Python.
- pkgver = 3.0.beta4
+ pkgver = 3.1
pkgrel = 1
url = https://github.com/jeffshee/hidamari
arch = any
@@ -17,10 +17,11 @@ pkgbase = hidamari
depends = dconf
depends = python-requests
depends = gnome-desktop-4
+ depends = libwnck3
optdepends = vdpauinfo: Query and display VDPAU capabilities
optdepends = libappindicator-gtk3: tray icon support
optdepends = webkit2gtk: web video support
- source = git+https://github.com/jeffshee/hidamari.git#tag=v3.0-beta4
+ source = git+https://github.com/jeffshee/hidamari.git#tag=v3.1
sha256sums = SKIP
pkgname = hidamari
diff --git a/PKGBUILD b/PKGBUILD
index 8c72ad16f84d..900c16d9b2b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Ali Rohman <laymoth@pm.me>
pkgname=hidamari
-pkgver=3.0.beta4
-_pkgver=3.0-beta4
+pkgver=3.1
+_pkgver=3.1
pkgrel=1
pkgdesc='Video wallpaper for Linux. Written in Python.'
arch=('any')
url='https://github.com/jeffshee/hidamari'
license=('GPL3')
-depends=('python-gobject' 'python-pillow' 'python-pydbus' 'python-vlc' 'yt-dlp' 'dconf' 'python-requests' 'gnome-desktop-4')
+depends=('python-gobject' 'python-pillow' 'python-pydbus' 'python-vlc' 'yt-dlp' 'dconf' 'python-requests' 'gnome-desktop-4' 'libwnck3')
makedepends=('git' 'meson' 'gtk-update-icon-cache' 'desktop-file-utils')
optdepends=('vdpauinfo: Query and display VDPAU capabilities'
'libappindicator-gtk3: tray icon support'
@@ -23,4 +23,4 @@ build() {
package() {
meson install -C build --destdir "$pkgdir"
-} \ No newline at end of file
+}