summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Javier Araya Navarro2021-01-24 12:49:31 -0600
committerJorge Javier Araya Navarro2021-01-24 12:49:31 -0600
commit714877784064f82feed0dc0f63460c2a089f7720 (patch)
treebfae83cdc33677a71acfbd518a8c1bba4ed602be
downloadaur-714877784064f82feed0dc0f63460c2a089f7720.tar.gz
First commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD63
-rw-r--r--hide3
-rw-r--r--icon.svg91
-rw-r--r--io.heaps.hide.desktop9
6 files changed, 199 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba859457d93f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = hide
+ pkgdesc = an extensible editor for Heaps game engine
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/HeapsIO/hide
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = haxe
+ makedepends = git
+ depends = nwjs
+ provides = hide
+ conflicts = hide
+ source = hide-git::git+https://github.com/HeapsIO/hide.git#master
+ source = icon.svg
+ source = io.heaps.hide.desktop
+ source = hide
+ sha256sums = SKIP
+ sha256sums = 1255733ff1ad84f207a3850082f000d40023df5ec1415a3fa49ec3c6fcb50f12
+ sha256sums = 77965d8ea53498683700f448a0f9fed0aa08093ad8d09167682f29ab0e944e73
+ sha256sums = 8beda3dba210dc712fd3759109da10aac68f197413a591351b29518276bdb09d
+
+pkgname = hide-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4ab610c1a42d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+.DS_Store
+.idea
+*.log
+tmp/
+
+hide-git/
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0977eff781db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Jorge Araya Navarro <jorge@esavara.cr>
+pkgname=hide-git
+pkgbase=hide
+pkgver=0.1.0
+pkgrel=1
+epoch=
+pkgdesc="an extensible editor for Heaps game engine"
+arch=('i686' 'x86_64')
+url="https://github.com/HeapsIO/hide"
+license=('BSD')
+depends=('nwjs')
+makedepends=('haxe' 'git')
+provides=('hide')
+conflicts=('hide')
+source=(
+ "${pkgname}::git+https://github.com/HeapsIO/${pkgbase}.git#master"
+ "icon.svg"
+ "io.heaps.hide.desktop"
+ "hide"
+)
+sha256sums=('SKIP'
+ '1255733ff1ad84f207a3850082f000d40023df5ec1415a3fa49ec3c6fcb50f12'
+ '77965d8ea53498683700f448a0f9fed0aa08093ad8d09167682f29ab0e944e73'
+ '8beda3dba210dc712fd3759109da10aac68f197413a591351b29518276bdb09d')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/${pkgname}"
+
+ haxelib setup "${srcdir}/${pkgname}/haxelib"
+
+ haxelib git heaps https://github.com/HeapsIO/heaps
+ haxelib git castle https://github.com/ncannasse/castle
+ haxelib git hxbit https://github.com/ncannasse/hxbit
+ haxelib git hscript https://github.com/HaxeFoundation/hscript
+ haxelib git hxnodejs https://github.com/HaxeFoundation/hxnodejs
+ haxelib git domkit https://github.com/HeapsIO/domkit
+ haxelib git hx3compat https://github.com/HaxeFoundation/hx3compat
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+
+ haxelib setup "${srcdir}/${pkgname}/haxelib"
+ haxe --verbose hide.hxml
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+
+ install -Ddm755 "${pkgdir}/usr/share/hide"
+ cp -r ./bin/{libs,res,app.html,cdb.css,defaultProps.json,hide.js,package.json,package-cdb.json,style.css} "${pkgdir}/usr/share/hide/"
+
+ install -Dm644 "${srcdir}"/icon.svg "${pkgdir}"/usr/share/pixmaps/hide.svg
+ install -Dm645 "${srcdir}"/hide "${pkgdir}"/usr/bin/hide
+ install -Dm644 "${srcdir}"/io.heaps.hide.desktop "${pkgdir}"/usr/share/applications/hide.desktop
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/hide b/hide
new file mode 100644
index 000000000000..6b636b9a5fc4
--- /dev/null
+++ b/hide
@@ -0,0 +1,3 @@
+#!/usr/bin/env sh
+
+nw /usr/share/hide/
diff --git a/icon.svg b/icon.svg
new file mode 100644
index 000000000000..a038d0b5c69a
--- /dev/null
+++ b/icon.svg
@@ -0,0 +1,91 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ version="1.1"
+ preserveAspectRatio="none"
+ x="0px"
+ y="0px"
+ width="200"
+ height="200"
+ viewBox="0 0 200 200"
+ id="svg893"
+ sodipodi:docname="icon.svg"
+ inkscape:version="1.0.1 (3bc2e813f5, 2020-09-07)">
+ <metadata
+ id="metadata897">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title></dc:title>
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <sodipodi:namedview
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1"
+ objecttolerance="10"
+ gridtolerance="10"
+ guidetolerance="10"
+ inkscape:pageopacity="0"
+ inkscape:pageshadow="2"
+ inkscape:window-width="1920"
+ inkscape:window-height="1016"
+ id="namedview895"
+ showgrid="false"
+ fit-margin-top="0"
+ fit-margin-left="0"
+ fit-margin-right="0"
+ fit-margin-bottom="0"
+ inkscape:zoom="1.7008197"
+ inkscape:cx="46.022688"
+ inkscape:cy="103.34014"
+ inkscape:window-x="1920"
+ inkscape:window-y="27"
+ inkscape:window-maximized="1"
+ inkscape:current-layer="svg893" />
+ <defs
+ id="defs887">
+ <g
+ id="Layer0_0_FILL">
+ <path
+ fill="#ffffff"
+ stroke="none"
+ d="m 103.15,62.5 h -0.85 l 0.25,0.05 h 0.3 l 0.3,-0.05 M 221.3,42.2 q -2.4,1.35 -3.9,3.9 -1.45,2.55 -1.5,6.2 0.05,3.65 1.5,6.2 1.5,2.55 3.9,3.9 2.45,1.35 5.25,1.35 2.8,0 5.2,-1.35 2.45,-1.35 3.9,-3.9 1.5,-2.55 1.55,-6.2 -0.05,-3.65 -1.55,-6.2 -1.45,-2.55 -3.9,-3.9 -2.4,-1.3 -5.2,-1.35 -2.8,0.05 -5.25,1.35 m 5.25,3.9 q 2,0.05 3,1.7 1.05,1.65 1.05,4.5 0,2.9 -1.05,4.55 -1,1.65 -3,1.65 -2,0 -3,-1.65 -1,-1.65 -1,-4.55 0,-2.85 1,-4.5 1,-1.65 3,-1.7 M 56.45,68.95 H 55 L 50.85,80.7 H 50.8 L 46.6,68.95 H 45.2 V 83.5 h 0.9 v -9.55 q 0,-0.9 -0.05,-1.95 0,-1.05 -0.05,-2 h 0.1 l 4.25,11.9 h 0.9 L 55.5,70 h 0.1 q -0.05,0.95 -0.1,2 -0.05,1.05 -0.05,1.95 v 9.55 h 1 V 68.95 m 11.2,0.9 h 6.9 v -0.9 h -7.9 V 83.5 h 8.15 v -0.9 h -7.15 v -6.4 h 5.8 v -0.85 h -5.8 v -5.5 m -35.8,-0.9 H 30.8 L 25.7,83.5 h 1 l 1.7,-5 h 5.8 l 1.65,5 h 1.1 l -5.1,-14.55 m -0.5,0.95 q 0.4,1.35 0.8,2.55 0.4,1.2 0.8,2.5 l 0.95,2.7 h -5.15 l 0.9,-2.7 q 0.45,-1.3 0.85,-2.5 0.4,-1.2 0.75,-2.55 h 0.1 m 100.8,2.8 q 0.65,-1.45 1.85,-2.25 1.2,-0.8 2.85,-0.8 1.2,0 2,0.4 0.8,0.45 1.35,1.05 l 0.6,-0.65 q -0.4,-0.4 -0.95,-0.8 -0.5,-0.4 -1.25,-0.65 -0.75,-0.3 -1.75,-0.3 -1.9,0 -3.35,0.9 -1.45,0.95 -2.25,2.6 -0.8,1.7 -0.8,4 0,2.35 0.75,4 0.8,1.7 2.2,2.6 1.4,0.95 3.25,0.95 1.45,0 2.55,-0.45 1.1,-0.45 1.75,-1.2 v -5.75 h -4.4 V 77.2 H 140 v 4.55 q -0.55,0.5 -1.4,0.8 -0.85,0.3 -1.85,0.3 -1.65,-0.05 -2.85,-0.85 -1.15,-0.8 -1.8,-2.3 -0.6,-1.5 -0.6,-3.5 0,-2 0.65,-3.5 m 19.45,-3.75 h -1 V 83.5 h 1 V 68.95 m -39.05,0 H 111.5 V 83.5 h 0.95 v -9 q 0,-1.1 -0.05,-2.1 -0.05,-1 -0.1,-2.05 h 0.1 l 7.75,13.15 h 1.05 V 68.95 h -0.95 v 8.95 q 0,1.05 0.05,2.1 0.05,1.05 0.1,2.1 h -0.1 l -7.75,-13.15 m -10.35,0.9 v -0.9 H 94.3 V 83.5 h 8.15 V 82.6 H 95.3 v -6.4 h 5.8 v -0.85 h -5.8 v -5.5 h 6.9 m 69.3,-0.9 h -0.95 v 8.95 q 0,1.05 0.05,2.1 0.05,1.05 0.1,2.1 h -0.1 L 162.85,68.95 H 161.8 V 83.5 h 0.95 v -9 q 0,-1.1 -0.05,-2.1 -0.05,-1 -0.1,-2.05 h 0.1 l 7.75,13.15 h 1.05 V 68.95 m 18.1,0.9 v -0.9 h -7.9 V 83.5 h 8.15 v -0.9 h -7.15 v -6.4 h 5.8 v -0.85 h -5.8 v -5.5 h 6.9 m 6.3,-13.05 q -1.05,1.1 -1.1,2.9 0.05,1.75 1.1,2.9 1.1,1.1 2.85,1.15 1.7,-0.05 2.8,-1.15 1.05,-1.15 1.1,-2.9 -0.05,-1.8 -1.1,-2.9 -1.1,-1.15 -2.8,-1.2 -1.75,0.05 -2.85,1.2 m 17.2,-15.45 h -6.5 v 21.9 h 6.5 v -21.9 m -0.55,-9 q -1.05,-0.9 -2.7,-0.95 -1.65,0.05 -2.7,0.95 -1,0.9 -1.05,2.4 0.05,1.55 1.05,2.45 1.05,0.95 2.7,0.95 1.65,0 2.7,-0.95 1,-0.9 1.05,-2.45 -0.05,-1.5 -1.05,-2.4 M 11.1,70.45 q 1.2,-0.8 2.85,-0.8 1.2,0 2,0.4 0.8,0.45 1.35,1.05 l 0.6,-0.65 q -0.4,-0.4 -0.95,-0.8 -0.5,-0.4 -1.25,-0.65 -0.75,-0.3 -1.75,-0.3 -1.9,0 -3.35,0.9 -1.45,0.95 -2.25,2.6 -0.8,1.7 -0.8,4 0,2.35 0.75,4 0.8,1.7 2.2,2.6 1.4,0.95 3.25,0.95 1.45,0 2.55,-0.45 1.1,-0.45 1.75,-1.2 v -5.75 h -4.4 v 0.85 h 3.45 v 4.55 q -0.55,0.5 -1.4,0.8 -0.85,0.3 -1.85,0.3 Q 12.2,82.8 11,82 9.85,81.2 9.2,79.7 8.6,78.2 8.6,76.2 q 0,-2 0.65,-3.5 0.65,-1.45 1.85,-2.25 M 36.05,36.85 H 17.8 V 19.25 H 7.9 V 63.3 h 9.9 V 45.35 H 36.05 V 63.3 h 10 V 19.25 h -10 v 17.6 m 39.7,8.3 v -8 H 61.3 v -9.8 h 15.5 v -8.1 H 51.4 V 63.3 H 77.85 V 55.2 H 61.3 V 45.15 H 75.75 M 94.85,34.4 q 0.2,-0.1 0.6,-0.1 l 2.4,-0.15 q 0.25,-0.55 0.75,-0.4 0.1,-0.5 0.8,-0.35 0.8,0.15 0.95,0.15 -0.4,-0.3 -0.45,-0.55 -0.15,-0.45 0.15,-0.65 0.2,-0.1 0.7,0.15 0.75,0.3 1.5,0.55 -0.45,-0.2 -0.55,-0.75 0,-0.35 0.3,-0.5 0.15,-0.1 0.45,-0.05 0.25,0.1 0.6,0.35 0.2,0.1 0.6,0.4 0.3,0.2 1.05,0.55 0.35,0.2 0.9,0.7 v 0.05 q 0.2,0.2 0.4,0.35 0.5,0.5 0.5,0.6 v 0.05 q 1.5,0.4 3,1.15 2.55,1.4 4.2,3.25 1.55,1.8 2,4.15 h -1.75 l -0.1,1.45 -0.15,1.8 -0.8,-0.5 -2.25,-1.45 -7.85,3.8 q 3.7,6.15 12.7,6.4 -1.15,2.15 -3,3.9 -2.25,2.2 -5.3,3.15 -0.5,0.15 -1,0.3 0,0.3 0,0.55 0,0.4 -0.05,0.8 H 124.4 L 102.75,4 80.95,63.55 h 17.7 q -0.1,-0.45 -0.1,-0.95 0,-0.3 0,-0.6 -0.75,-0.25 -1.5,-0.6 -2.7,-1.25 -4.65,-3.4 -1.95,-2.1 -2.9,-4.8 -1.05,-2.85 -0.8,-5.85 0.25,-3 1.5,-5.45 0.9,-1.75 2.2,-3.15 0.7,-1.15 1.85,-1.7 l -0.8,-0.1 q -0.5,-0.1 -0.5,-0.5 0,-0.2 0.3,-0.45 0.95,-0.8 2.15,-0.75 -0.6,-0.05 -0.75,-0.3 -0.2,-0.3 0.2,-0.55 m 60.25,9.65 q 4.75,-4.15 4.75,-10.75 0,-14.05 -16.6,-14.05 h -15.6 V 63.3 h 9.9 V 48.15 h 4.8 q 7.95,0 12.75,-4.1 M 137.55,40.6 V 26.85 h 3.95 q 7.9,0 7.9,6.85 0,6.9 -7.9,6.9 h -3.95 M 191.3,20.85 q -2.25,-0.8 -4.95,-1.2 -2.65,-0.4 -6.05,-0.4 -3.55,0 -6.65,0.65 -3.15,0.75 -5.5,2.35 -2.4,1.5 -3.8,3.95 -1.35,2.4 -1.35,5.7 0,4.25 2.55,7.3 2.5,2.95 7.65,5.1 2.05,0.8 3.8,1.55 1.7,0.8 3,1.65 1.3,0.8 2,1.8 0.75,0.95 0.75,2.25 0,0.9 -0.5,1.7 -0.4,0.8 -1.35,1.4 -0.9,0.55 -2.3,0.8 -1.4,0.4 -3.3,0.4 -3.2,0 -6.35,-1.05 -3.15,-1.15 -5.8,-3.3 v 9.55 q 2.4,1.15 5.7,1.75 3.25,0.65 6.85,0.65 3.55,0 6.7,-0.7 3.25,-0.65 5.6,-2.1 2.4,-1.55 3.85,-4 1.35,-2.4 1.35,-6 0,-2.6 -0.8,-4.5 -0.8,-1.95 -2.35,-3.5 -1.45,-1.55 -3.55,-2.7 -2.15,-1.25 -4.75,-2.3 -1.95,-0.75 -3.45,-1.5 -1.6,-0.75 -2.65,-1.55 -1.05,-0.75 -1.65,-1.5 -0.6,-0.9 -0.6,-2.05 0,-0.95 0.55,-1.7 0.5,-0.8 1.45,-1.35 0.95,-0.6 2.35,-0.9 1.35,-0.3 3.05,-0.3 1.3,0 2.65,0.15 1.35,0.2 2.7,0.6 1.4,0.3 2.7,0.9 1.3,0.55 2.45,1.3 z"
+ id="path884" />
+ </g>
+ </defs>
+ <rect
+ style="fill:#8b1d4e;fill-opacity:1;stroke:none;stroke-width:22.008;stroke-linecap:round;stroke-miterlimit:4;stroke-dasharray:none"
+ id="rect899"
+ width="200"
+ height="200"
+ x="0"
+ y="0"
+ ry="0"
+ rx="0" />
+ <g
+ transform="matrix(0.81200243,0,0,0.81200243,19.396167,9.9803278)"
+ id="g891">
+ <g
+ id="use889"
+ transform="matrix(1.4659579,0,0,1.4659579,3.2434632,-14.85836)">
+ <path
+ fill="#ffffff"
+ stroke="none"
+ d="M 92.905221,72.397136 H 37.795264 V 19.25 H 7.9 V 152.26883 H 37.795264 V 98.064787 H 92.905221 V 152.26883 H 123.10246 V 19.25 H 92.905221 v 53.147136"
+ id="path901"
+ sodipodi:nodetypes="ccccccccccccc"
+ style="stroke-width:3.01972" />
+ </g>
+ </g>
+</svg>
diff --git a/io.heaps.hide.desktop b/io.heaps.hide.desktop
new file mode 100644
index 000000000000..edc2410d4920
--- /dev/null
+++ b/io.heaps.hide.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Hide
+Comment=An extensible editor for Heaps game engine
+Icon=hide
+Exec=hide
+Terminal=false
+PrefersNonDefaultGPU=true
+Type=Application
+Categories=Development;IDE;Database;