summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortadly2017-09-01 13:11:37 +0200
committertadly2017-09-01 13:23:42 +0200
commit9af0d6964cff03a57ad778a761fe569bcd03c861 (patch)
treecf993ab16e6e094b5a247eca4a1dec6377aff589
downloadaur-9af0d6964cff03a57ad778a761fe569bcd03c861.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb87f5a8d337
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Sep 1 11:23:35 UTC 2017
+pkgbase = hideit.sh-git
+ pkgdesc = Automagically hide/show a window
+ pkgver = a1a05c9
+ pkgrel = 1
+ url = https://github.com/Tadly/hideIt.sh
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = xdotool
+ depends = xorg-xwininfo
+ depends = xorg-xev
+ provides = hideIt.sh
+ source = hideIt.sh::git+https://github.com/Tadly/hideIt.sh.git
+ md5sums = SKIP
+
+pkgname = hideit.sh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85d02866fe27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+_pkgname=hideIt.sh
+pkgname=hideit.sh-git
+pkgver=a1a05c9
+pkgrel=1
+pkgdesc="Automagically hide/show a window"
+arch=('i686' 'x86_64')
+url="https://github.com/Tadly/hideIt.sh"
+license=('GPL3')
+depends=('xdotool' 'xorg-xwininfo' 'xorg-xev')
+provides=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/Tadly/hideIt.sh.git")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git rev-parse --short HEAD
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 ${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
+}