summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Hinshaw2018-04-19 22:30:57 -0400
committerCorey Hinshaw2018-04-19 22:30:57 -0400
commit4a15a0bdb925060f3b7165495bf5958071c09639 (patch)
treef59df9b32ac26a8f307ff444ff5ecbfb67476ba1
downloadaur-4a15a0bdb925060f3b7165495bf5958071c09639.tar.gz
Initial commit, version 17.10.3
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afdd35a691a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hidpi-daemon
+ pkgdesc = Daemon to manage HiDPI and LoDPI monitors on X
+ pkgver = 17.10.3
+ pkgrel = 1
+ url = https://github.com/pop-os/hidpi-daemon
+ arch = any
+ license = GPL
+ depends = python>=3.6
+ depends = python-pydbus
+ depends = python-gobject
+ depends = python-xlib
+ depends = libnotify
+ source = https://github.com/pop-os/hidpi-daemon/archive/17.10.3.tar.gz
+ sha1sums = 3445b11aaef52f3a53818bd8f31bf9c16f137eee
+
+pkgname = hidpi-daemon
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0cced017d91a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.tar.gz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14f61ee13169
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Corey Hinshaw <coreyhinshaw(at)gmail(dot)com>
+
+pkgname=hidpi-daemon
+pkgver=17.10.3
+pkgrel=1
+pkgdesc="Daemon to manage HiDPI and LoDPI monitors on X"
+arch=('any')
+url="https://github.com/pop-os/hidpi-daemon"
+license=('GPL')
+depends=(
+ 'python>=3.6'
+ 'python-pydbus'
+ 'python-gobject'
+ 'python-xlib'
+ 'libnotify')
+makepdepends=(
+ 'python-pyflakes')
+source=(
+ "https://github.com/pop-os/${pkgname}/archive/${pkgver}.tar.gz")
+sha1sums=(
+ '3445b11aaef52f3a53818bd8f31bf9c16f137eee')
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ # Build and install base package
+ python setup.py install --prefix=/usr --root=${pkgdir} --optimize=1
+
+ # Install daemons and executables
+ install -m755 -D hidpi-daemon ${pkgdir}/usr/lib/${pkgname}/hidpi-daemon
+ install -m755 -D hidpi-notification ${pkgdir}/usr/lib/${pkgname}/hidpi-notification
+
+ # Install desktop launchers
+ install -m644 -D hidpi-daemon.desktop ${pkgdir}/etc/xdg/autostart/hidpi-daemon.desktop
+ install -m644 -D hidpi-frontend.desktop ${pkgdir}/etc/xdg/autostart/hidpi-frontend.desktop
+
+ # Install schema
+ install -m644 -D com.system76.hidpi.gschema.xml ${pkgdir}/usr/share/glib-2.0/schemas/com.system76.hidpi.gschema.xml
+
+ # Create empty /var/lib package directory
+ mkdir -p ${pkgdir}/var/lib/${pkgname}
+
+ # Clean up
+ rm -rf ${pkgdir}/usr/lib/python*/site-packages/hidpidaemon/{__pycache__,tests}
+}