summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-16 11:40:03 -0600
committerMark Wagie2021-10-16 11:40:03 -0600
commitfe3180a11d43cd9fe2c56131e2b4503298eb26c9 (patch)
tree9050ec726a871476cd4834e218e5e5e3bfbf5987
parent88dbf9ce6979e8b042f3cc13dcd5426052c3fbb3 (diff)
downloadaur-fe3180a11d43cd9fe2c56131e2b4503298eb26c9.tar.gz
adjustments
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD40
2 files changed, 18 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b66f9f358e6..3d0f15f16f52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = hidpi-daemon
pkgdesc = Daemon to manage HiDPI and LoDPI monitors on X
pkgver = 18.04.6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/pop-os/hidpi-daemon
arch = any
license = GPL2
depends = acpid
- depends = python>=3.6
- depends = python-pydbus
+ depends = libnotify
depends = python-gobject
+ depends = python-pydbus
depends = python-xlib
- depends = libnotify
- source = https://github.com/pop-os/hidpi-daemon/archive/18.04.6.tar.gz
+ source = hidpi-daemon-18.04.6.tar.gz::https://github.com/pop-os/hidpi-daemon/archive/18.04.6.tar.gz
sha256sums = ecb6135128c84dd37499c642d017ee663d7e91479806b8d67d1452fb1769c370
pkgname = hidpi-daemon
diff --git a/PKGBUILD b/PKGBUILD
index 6622b07d5cd7..9f9481d5783e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,27 @@
# Contributor: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=hidpi-daemon
pkgver=18.04.6
-pkgrel=2
+pkgrel=3
pkgdesc="Daemon to manage HiDPI and LoDPI monitors on X"
arch=('any')
url="https://github.com/pop-os/hidpi-daemon"
license=('GPL2')
-depends=(
- 'acpid'
- 'python>=3.6'
- 'python-pydbus'
- 'python-gobject'
- 'python-xlib'
- 'libnotify')
-source=("https://github.com/pop-os/hidpi-daemon/archive/${pkgver}.tar.gz")
+depends=('acpid' 'libnotify' 'python-gobject' 'python-pydbus' 'python-xlib')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('ecb6135128c84dd37499c642d017ee663d7e91479806b8d67d1452fb1769c370')
-package() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
- # Build and install base package
- export PYTHONHASHSEED=0
- python setup.py install --root=${pkgdir} --optimize=1 --skip-build
-
- # Install daemons and executables
- install -m755 -D hidpi-daemon ${pkgdir}/usr/lib/${pkgname}/hidpi-daemon
- install -m755 -D hidpi-notification ${pkgdir}/usr/lib/${pkgname}/hidpi-notification
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
- # Install desktop launchers
- install -m644 -D hidpi-daemon.desktop ${pkgdir}/etc/xdg/autostart/hidpi-daemon.desktop
- install -m644 -D hidpi-frontend.desktop ${pkgdir}/etc/xdg/autostart/hidpi-frontend.desktop
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- # Install schema
- install -m644 -D com.system76.hidpi.gschema.xml ${pkgdir}/usr/share/glib-2.0/schemas/com.system76.hidpi.gschema.xml
- # Create empty /var/lib package directory
- install -d ${pkgdir}/var/lib/${pkgname}
+ install -Dm755 "$pkgname" hidpi-notification prime-dialog -t "$pkgdir/usr/lib/$pkgname"
+ install -Dm644 "$pkgname.desktop" hidpi-frontend.desktop -t "$pkgdir/etc/xdg/autostart"
+ install -Dm644 com.system76.hidpi.gschema.xml -t "$pkgdir/usr/share/glib-2.0/schemas"
+ install -d "$pkgdir/var/lib/$pkgname"
}