summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClayton Craft2017-05-07 13:17:12 -0700
committerClayton Craft2017-05-07 13:17:12 -0700
commit6d54e1bc0b6d8000d88ad0443732b7450405782d (patch)
tree7d24c10ddc4a1ff8b8defccf9bce8cb5dc862388
downloadaur-6d54e1bc0b6d8000d88ad0443732b7450405782d.tar.gz
initial release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..010fcbb40d39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hidviz
+ pkgdesc = Tool for in-depth analysis of USB HID devices communication
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/ondrejbudai/hidviz
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = libusb
+ depends = protobuf
+ depends = qt5-base
+ depends = cmake
+ provides = hidviz
+ conflicts = hidviz
+ source = http://hidviz.org/releases/hidviz-0.1.3.tar.gz
+ sha256sums = 8ac8df2712ad1b88c824d591d53230ec0f923ffeb1f1dc20126c1e55ee84b5e0
+
+pkgname = hidviz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c69542e0c8bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Clayton Craft <clayton at craftyguy dot net>
+pkgname=hidviz
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Tool for in-depth analysis of USB HID devices communication"
+arch=('i686' 'x86_64')
+url="https://github.com/ondrejbudai/hidviz"
+license=('GPL3')
+depends=('libusb' 'protobuf' 'qt5-base' 'cmake')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=("http://hidviz.org/releases/$pkgname-$pkgver.tar.gz")
+sha256sums=('8ac8df2712ad1b88c824d591d53230ec0f923ffeb1f1dc20126c1e55ee84b5e0')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}"/usr -DCMAKE_INSTALL_LIBDIR="${pkgdir}"/usr/lib ..
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"/build
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"/build
+ make install
+ # The following is a nasty workaround for the package author having to
+ # comply with Fedora packaging requirements.
+ mv "${pkgdir}"/usr/lib/hidviz/* "${pkgdir}"/usr/lib
+ rmdir "${pkgdir}"/usr/lib/hidviz
+}
+