aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Tharp2017-02-03 14:23:38 -0600
committerAlex Tharp2017-02-03 14:23:38 -0600
commit650d01ddeb63301c5921efe5297faa66943bc0bc (patch)
tree278fcc6dd486b0742e5de62035a7c9bb7d8350fd
parent042116b5494ef690d04d5288fc1b8d801c2c93fc (diff)
downloadaur-650d01ddeb63301c5921efe5297faa66943bc0bc.tar.gz
chore: point to proper license, add provides and conflicts, set correct cmake_install_prefix path
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 800ddaf76ee2..f5a16d9744c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Thu Feb 2 07:34:38 UTC 2017
+# Fri Feb 3 20:22:21 UTC 2017
pkgbase = hifi-git
pkgdesc = High Fidelity is an open, decentralized virtual world using sensors to control avatars and dynamically assigned devices as servers. This provides the client, servers and dev tools. (git - master)
pkgver = r50816.f4e57898c6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/highfidelity/hifi
install = hifi-git.install
arch = i686
arch = x86_64
- license = Apache2
+ license = Apache
makedepends = git
makedepends = cmake>=2.8.12.2
depends = qt5-base>=5.5.1
@@ -34,6 +34,8 @@ pkgbase = hifi-git
depends = bullet>=2.82
depends = libsoxr>=0.1.1
depends = qxmpp-qt5
+ provides = hifi
+ conflicts = hifi
source = hifi::git+https://github.com/highfidelity/hifi.git
source = gverb::git+https://github.com/highfidelity/gverb.git
source = hifi-interface.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 073506a7658a..bb40fddf0391 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Alex Tharp <toastercup@gmail.com>
-# Upstream URL: https://github.com/highfidelity/hifi
pkgname=hifi-git
pkgver=r50816.f4e57898c6
-pkgrel=1
+pkgrel=2
pkgdesc="High Fidelity is an open, decentralized virtual world using sensors to control avatars and dynamically assigned devices as servers. This provides the client, servers and dev tools. (git - master)"
arch=('i686' 'x86_64')
url="https://github.com/highfidelity/hifi"
-license=('Apache2')
+license=('Apache')
install="${pkgname}.install"
makedepends=('git' 'cmake>=2.8.12.2')
+provides=('hifi')
+conflicts=('hifi')
_qt5version=5.5.1
depends=("qt5-base>=$_qt5version"
"qt5-script>=$_qt5version"
@@ -71,7 +72,7 @@ prepare() {
build() {
cd $srcdir && mkdir -p build && cd $_
- cmake -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/opt/interface" -DCMAKE_BUILD_TYPE:STRING=Release "../$_githifi"
+ cmake -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/opt/hifi/interface" -DCMAKE_BUILD_TYPE:STRING=Release "../$_githifi"
make
}