summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuey-Liang Kao2017-04-08 23:14:56 +0800
committerQuey-Liang Kao2017-04-08 23:14:56 +0800
commit0cf1ad12f813d31184ff295d17d1a386df5ed028 (patch)
tree5bde9baa982eb6b52b01bed92c991de4189676a1
parent90fc5037b3bac1d1da0ad905b0b1e74f8bff2cc2 (diff)
downloadaur-0cf1ad12f813d31184ff295d17d1a386df5ed028.tar.gz
Split the directory structure into two
To use previous versions, one should copy the whole bunch of the subdirectory under /opt/hifive1-sdk, which is a duplication because in theory, the toolchain and binary utils doesn't have to be moved. After this patch, the user now can copy a smaller amount of required files: the example applications, the platform-specific settings, and the makefile which plays the main role of the development flow. Also, the message after installation is more comprehensive now.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
-rw-r--r--hifive1-sdk.install26
3 files changed, 33 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4edd4385959f..416af4c239dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = hifive1-sdk-git
- pkgdesc = The Official SDK of the RISC-V-based HiFive Board
- pkgver = r94.b7c778c
+ pkgdesc = The Official SDK of the RISC-V-based HiFive1 Board (and Arty)
+ pkgver = r97.3a01ac1
pkgrel = 1
url = https://www.sifive.com/
install = hifive1-sdk.install
arch = x86_64
license = APACHE
makedepends = git
- depends = libunistring>=0.9.7
depends = flex-git
+ depends = libunistring
options = !strip
source = git+https://github.com/sifive/freedom-e-sdk.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0046e2661450..1598b2f4faf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Quey-Liang Kao<s101062801@m101.nthu.edu.tw>
pkgname=hifive1-sdk-git
-pkgver=r94.b7c778c
+pkgver=r97.3a01ac1
pkgrel=1
-pkgdesc="The Official SDK of the RISC-V-based HiFive Board"
-depends=('libunistring>=0.9.7' 'flex-git')
+pkgdesc="The Official SDK of the RISC-V-based HiFive1 Board (and Arty)"
+depends=('flex-git' 'libunistring')
makedepends=('git')
arch=('x86_64')
source=("git+https://github.com/sifive/freedom-e-sdk.git")
@@ -28,11 +28,16 @@ build() {
package() {
cd $srcdir/freedom-e-sdk
- mkdir -p $pkgdir/opt/hifive1-sdk
- cp -r toolchain $pkgdir/opt/hifive1-sdk/
- cp -r bsp $pkgdir/opt/hifive1-sdk/
- cp -r software $pkgdir/opt/hifive1-sdk/
- cp Makefile $pkgdir/opt/hifive1-sdk/
+ mkdir -p $pkgdir/opt
+ cp -r toolchain $pkgdir/opt/hifive1-sdk
+
+ mkdir -p $pkgdir/usr/share/hifive1-sdk
+ cp -r bsp $pkgdir/usr/share/hifive1-sdk/
+ cp -r software $pkgdir/usr/share/hifive1-sdk/
+ cp Makefile $pkgdir/usr/share/hifive1-sdk/.Makefile
+ cat $pkgdir/usr/share/hifive1-sdk/.Makefile | sed "s/^toolchain_dest.*/toolchain_dest := \/opt\/hifive1-sdk/" > $pkgdir/usr/share/hifive1-sdk/Makefile
+ mv $pkgdir/usr/share/hifive1-sdk/bsp/env/common.mk $pkgdir/usr/share/hifive1-sdk/bsp/env/.common.mk
+ cat $pkgdir/usr/share/hifive1-sdk/bsp/env/.common.mk | sed "s/^TOOL_DIR.*/TOOL_DIR = \/opt\/hifive1-sdk\/bin/" > $pkgdir/usr/share/hifive1-sdk/bsp/env/common.mk
}
pkgver() {
diff --git a/hifive1-sdk.install b/hifive1-sdk.install
index 97773105273d..324d97b360e3 100644
--- a/hifive1-sdk.install
+++ b/hifive1-sdk.install
@@ -1,11 +1,19 @@
post_install () {
- echo ">>> NOTE: Currently, the whole stuff are put in /opt/hifive-sdk."
- echo ">>> According to the guideline, this will be fixed soon."
- echo ">>> "
- echo ">>> The recommanded way to use this toolchain is to copy the"
- echo ">>> directory, and follow the Official Getting Start Guide. "
- echo ">>> Basically, make software PROGRAM=... "
- echo ">>> "
- echo ">>> There are still some linking issue, but demo_gpio is"
- echo ">>> buildable."
+ echo ">>> Usage: "
+ echo ">>> 1. add your working ID to group uucp."
+ echo ">>> "
+ echo ">>> $ sudo usermod -aG uucp my_id"
+ echo ">>> "
+ echo ">>> 2. copy /usr/share/hifive1-sdk directory to your own place."
+ echo ">>> "
+ echo ">>> 3. check \"make help\" to see instructions."
+ echo ">>> "
+ echo ">>> "
+ echo ">>> If you encounter any problem, please ask at the official forum:"
+ echo ">>> https://forums.sifive.com/t/arch-linux-and-the-hifive1/212/21"
+ echo ">>> or the AUR package site:"
+ echo ">>> https://aur.archlinux.org/packages/hifive1-sdk-git/"
+ echo ">>> "
+ echo ">>> "
+ echo ">>> Happy Hacking!"
}