summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2019-03-03 17:35:44 +0900
committerQue Quotion2019-03-03 17:35:44 +0900
commit6059be3af48f98a0a02f97ea272ec3ff8f3e446f (patch)
treee17c84f0aacf1c94514cc535cb3b488b08715b4a
parent50f6e60d57da05c95134ff633283cc8e36e04305 (diff)
downloadaur-6059be3af48f98a0a02f97ea272ec3ff8f3e446f.tar.gz
Run through clean chroot; makedepends updates; other minor fixes--switch back to standard build (comment out PGO section)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 41 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f18fded82fe3..e9614043ab63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,22 @@
-# Generated by mksrcinfo v8
-# Tue Feb 21 13:11:20 UTC 2017
pkgbase = higan-qq
pkgdesc = A Nintendo multi-system emulator with quequotion's customizations
pkgver = 094.8d4b3cfa
- pkgrel = 2
- url = http://byuu.org/higan/
+ pkgrel = 3
+ url = https://github.com/quequotion/higan-qq
install = higan.install
arch = i686
arch = x86_64
license = GPL
+ makedepends = git
+ makedepends = libao
+ makedepends = libpulse
+ makedepends = libx11
+ makedepends = libxv
+ makedepends = gtk2
+ makedepends = gtksourceview2
+ makedepends = sdl
+ makedepends = mesa-libgl
+ makedepends = openal
replaces = higan-qq-git
source = higan::git+https://github.com/quequotion/higan-qq.git
source = profilebatch
@@ -20,6 +28,7 @@ pkgbase = higan-qq
md5sums = 6ce8b7fef6432184d50124e26991a374
pkgname = higan-qq
+ pkgdesc = A Nintendo multi-system emulator with quequotion's customizations (multi-fork emulator)
depends = openal
depends = libgl
optdepends = alsa
@@ -31,4 +40,5 @@ pkgname = higan-qq
conflicts = bsnes
pkgname = libananke
+ pkgdesc = A Nintendo multi-system emulator with quequotion's customizations (rom importing library)
diff --git a/PKGBUILD b/PKGBUILD
index 91eec4de879c..54f1b1611911 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
pkgbase=higan-qq
pkgname=('higan-qq' 'libananke')
pkgver=094.8d4b3cfa
-pkgrel=2
+pkgrel=3
pkgdesc="A Nintendo multi-system emulator with quequotion's customizations"
arch=('i686' 'x86_64')
-url=http://byuu.org/higan/
+url=https://github.com/quequotion/higan-qq
license=(GPL)
replaces=('higan-qq-git')
+makedepends=('git' lib{ao,pulse,x{11,v}} gtk{,sourceview}2 {sd,mesa-libg,opena}l)
source=('higan::git+https://github.com/quequotion/higan-qq.git'
'profilebatch'
'super-fx-hax.patch'
@@ -17,13 +18,18 @@ md5sums=('SKIP'
'480577daf0602cd5eabac698a4a2e310'
'6ce8b7fef6432184d50124e26991a374')
-_profile="accuracyfast"
-
+#Accuracyfast swapps byuu's functionally accurate dsp for
+#blarrg's output-accurate dsp; allegedly improving performance.
+#Keep in mind, the purpose is to run bsnes at 60fps for playing games
+#not TAS, but only because Bizhawk is beyond my understanding (087?).
+
+_profile="accuracyfast"
+
pkgver() {
cd "higan"
echo 094.$( git describe --always | sed 's#-#_#g;s#v##' )
}
-
+
prepare(){
cd "${srcdir}/higan"
@@ -38,10 +44,10 @@ prepare(){
patch -Np2 < "${srcdir}/super-fx-hax.patch"
#Append user's CXXFLAGS and LDFLAGS
- sed -i "\|^flags += -I. -O3 -fomit-frame-pointer| s|$| -std=gnu++11 $CXXFLAGS|" Makefile
- sed -i "\|^link +=| s|$| $LDFLAGS|" Makefile
+ sed -i "\|^flags :=| s|$| $CFLAGS|" nall/Makefile
+ sed -i "\|^link :=| s|$| $LDFLAGS|" nall/Makefile
}
-
+
build(){
cd "${srcdir}/higan"
@@ -50,9 +56,9 @@ build(){
compiler=g++ \
platform=linux \
-C ananke
-
+
# higan
- # Normal build
+ # Normal build (doesn't work with makepkg-optimize's pgo macro for reasons unkown)
make \
compiler=g++ \
platform=linux \
@@ -63,26 +69,32 @@ build(){
# Profile Guided Optimization build
#
# Build with profile generation
- make pgo=instrument compiler=g++ platform=linux target=higan profile=${_profile} name=higan-${_profile}
+ #make pgo=instrument compiler=g++ platform=linux target=higan profile=${_profile}
+name=higan-${_profile}
#
# Run all cores and SFC special chips (except the new (famicom variant) nSide systems (Playchoice 10, VS System))
- "${srcdir}/profilebatch" "out/higan-${_profile}" "/home/${USER}/Emulation/"
+ #"${srcdir}/profilebatch" "out/higan-${_profile}" "/home/${USER}/ROMS/higan"
#
# Build with profile analysis
- make clean
- make pgo=optimize compiler=g++ platform=linux target=higan profile=${_profile} name=higan-${_profile}
+ #make clean
+ #make pgo=optimize compiler=g++ platform=linux target=higan profile=${_profile} name=higan-${_profile}
+
+ #Generic build; leave pgo, etc up to the package manager (makepkg-optimize)
+ #make compiler=g++ platform=linux target=higan name=higan-${_profile}
+
}
package_libananke(){
+ pkgdesc+=" (rom importing library)"
cd "${srcdir}/higan"
#if [ ! -d ~/.config/ananke ]; then install -d ~/.config/ananke; fi
make DESTDIR=${pkgdir} prefix=/usr/lib -C ananke install
}
package_higan-qq(){
+ pkgdesc+=" (multi-fork emulator)"
provides=(higan{,-qq})
conflicts=('higan' 'bsnes')
- makedepend=('libao' 'git' 'gtksourceview2')
depends=('openal' 'libgl')
optdepends=('alsa' 'pulseaudio' 'sdl')
cd "${srcdir}/higan"