summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Jagieniak2019-05-21 00:46:00 +0200
committerJustin Jagieniak2019-05-21 00:46:00 +0200
commit530ffa64b8945be9a3d9c87a1e99eb654b4c7654 (patch)
treef8786c0dc85b6d951179792d75ba8ca9abf3a355
parent7ff685d22b0cf4713f85bb1cfee9de31715d54f9 (diff)
downloadaur-530ffa64b8945be9a3d9c87a1e99eb654b4c7654.tar.gz
Add missing extern libraries to /usr/lib
-rw-r--r--PKGBUILD22
1 files changed, 21 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7ba5a83f91b..029c69a5bc1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=high-fidelity-stable-git
pkgver=r77707.576f41f90c
-pkgrel=1.02
+pkgrel=1.1
pkgdesc="High Fidelity (Hifi) is an open-source software where you can create and share virtual reality (VR) experiences. Create and host your own VR world, explore other worlds and meet other users. (git - latest stable version)"
arch=('i686' 'x86_64')
url="https://github.com/highfidelity/hifi"
@@ -75,11 +75,31 @@ build() {
package() {
mkdir -p "$pkgdir/usr/share/hifi"
mkdir -p "$pkgdir/opt/hifi"
+ mkdir -p "$pkgdir/usr/lib/hifi"
+
cd "$srcdir/build"
make install
+ #copy polyvox library
+ cp "$srcdir/build/ext/makefiles/polyvox/project/lib/Release/libPolyVoxCore.so.0.2.1" "$pkgdir/usr/lib/"
+ cp "$srcdir/build/ext/makefiles/polyvox/project/lib/Release/libPolyVoxCore.so.0" "$pkgdir/usr/lib/"
+ cp "$srcdir/build/ext/makefiles/polyvox/project/lib/Release/libPolyVoxCore.so" "$pkgdir/usr/lib/"
+
+ cp "$srcdir/build/ext/makefiles/polyvox/project/lib/libPolyVoxUtil.so.0.2.1" "$pkgdir/usr/lib/"
+ cp "$srcdir/build/ext/makefiles/polyvox/project/lib/libPolyVoxUtil.so.0" "$pkgdir/usr/lib/"
+ cp "$srcdir/build/ext/makefiles/polyvox/project/lib/libPolyVoxUtil.so" "$pkgdir/usr/lib/"
+
+ #copy quazip library
+ cp "$srcdir/build/ext/makefiles/quazip/project/lib/libquazip5.so.1.0.0" "$pkgdir/usr/lib/"
+ cp "$srcdir/build/ext/makefiles/quazip/project/lib/libquazip5.so.1" "$pkgdir/usr/lib/"
+ cp "$srcdir/build/ext/makefiles/quazip/project/lib/libquazip5.so" "$pkgdir/usr/lib/"
+
+ #copy steamworks libsdkencryptedappticket libsteam api
+ cp "$srcdir/build/ext/makefiles/steamworks/project/src/steamworks/public/steam/lib/linux64/libsdkencryptedappticket.so" "$pkgdir/usr/lib/hifi/"
+ cp "$srcdir/build/ext/makefiles/steamworks/project/src/steamworks/redistributable_bin/linux64/libsteam_api.so" "$pkgdir/usr/lib/hifi/"
+
install -Dm644 "$srcdir/hifi-interface.png" "$pkgdir/usr/share/hifi/hifi-interface.png"
install -Dm644 "$srcdir/hifi-interface.desktop" "$pkgdir/usr/share/applications/hifi-interface.desktop"
install -Dm755 "$srcdir/hifi-interface.launcher" "$pkgdir/usr/bin/hifi-interface"