summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Jagieniak2019-05-20 22:49:55 +0200
committerJustin Jagieniak2019-05-20 22:49:55 +0200
commitd661c73b3a6c6c540fcdb6a6670711ddfcf08e00 (patch)
tree7da21cba850e5bd3735116468a65a1081b658739
parentfb4a521de979965cf8611f17a6d14e4a0856adaa (diff)
downloadaur-d661c73b3a6c6c540fcdb6a6670711ddfcf08e00.tar.gz
fix make install
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6ee19795166..e6bfac09dff9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = high-fidelity-stable-git
pkgdesc = High Fidelity (Hifi) is an open-source software where you can create and share virtual reality (VR) experiences. Create and host your own VR world, explore other worlds and meet other users. (git - latest stable version)
pkgver = r77707.576f41f90c
- pkgrel = 1.01
+ pkgrel = 1.02
url = https://github.com/highfidelity/hifi
install = high-fidelity-stable-git.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 397a60f8fb18..e7ba5a83f91b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=high-fidelity-stable-git
pkgver=r77707.576f41f90c
-pkgrel=1.01
+pkgrel=1.02
pkgdesc="High Fidelity (Hifi) is an open-source software where you can create and share virtual reality (VR) experiences. Create and host your own VR world, explore other worlds and meet other users. (git - latest stable version)"
arch=('i686' 'x86_64')
url="https://github.com/highfidelity/hifi"
@@ -68,17 +68,17 @@ pkgver() {
build() {
cd "$srcdir/build"
- cmake -DQT_CMAKE_PREFIX_PATH="/usr/lib/cmake" ..
+ cmake -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/opt/hifi" -DCMAKE_BUILD_TYPE:STRING="Release" -DQT_CMAKE_PREFIX_PATH:PATH="/usr/lib/cmake" ..
make
}
package() {
mkdir -p "$pkgdir/usr/share/hifi"
+ mkdir -p "$pkgdir/opt/hifi"
cd "$srcdir/build"
- # TODO: Clean makefiles here
- cp -R "$srcdir/build" "$pkgdir/opt/hifi"
+ make install
install -Dm644 "$srcdir/hifi-interface.png" "$pkgdir/usr/share/hifi/hifi-interface.png"
install -Dm644 "$srcdir/hifi-interface.desktop" "$pkgdir/usr/share/applications/hifi-interface.desktop"