summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Old2015-11-06 12:03:30 -0800
committerMark Old2015-11-06 12:03:30 -0800
commitf85348effb069dd74bf5aca9f647c66d168d11b0 (patch)
tree699aca4bd5d2e8bc1df005b42c97155486738ac7
downloadaur-f85348effb069dd74bf5aca9f647c66d168d11b0.tar.gz
match names
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8716f407392
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = highcommand-git
+ pkgdesc = getopt() for the future
+ pkgver = r51.91ef7d6
+ pkgrel = 1
+ url = https://github.com/dlom/highcommand
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = ruby-ronn
+ depends = glibc
+ provides = highcommand
+ conflicts = highcommand
+ source = git+https://github.com/dlom/highcommand.git
+ md5sums = SKIP
+
+pkgname = highcommand-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d78436e94d27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mark Old <dlom234@gmail.com>
+
+_gitname=highcommand
+pkgname=$_gitname-git
+pkgver=r51.91ef7d6
+pkgrel=1
+pkgdesc="getopt() for the future"
+url="https://github.com/dlom/highcommand"
+license=("MIT")
+depends=("glibc")
+makedepends=("ruby-ronn")
+arch=("i686" "x86_64")
+provides=("highcommand")
+conflicts=("highcommand")
+source=("git+https://github.com/dlom/$_gitname.git")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s\n" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_gitname"
+ make
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}