summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBao Trinh2023-04-03 20:31:44 -0500
committerBao Trinh2023-04-03 20:31:44 -0500
commitd47f4869866ffd3f36913ddfecd9540c8f429369 (patch)
tree2785e339d4a8592ab59009335bc8d98bdd6ae0a7
downloadaur-d47f4869866ffd3f36913ddfecd9540c8f429369.tar.gz
v0.2.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1355045df6c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = highlight-stderr
+ pkgdesc = Run a command and highlight its stderr, preserving the order of stdout and stderr
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/joshtriplett/highlight-stderr
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = cargo
+ depends = glibc
+ depends = gcc-libs
+ source = highlight-stderr-0.2.1.tar.gz::https://github.com/joshtriplett/highlight-stderr/archive/refs/tags/0.2.1.tar.gz
+ sha512sums = SKIP
+
+pkgname = highlight-stderr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83be3fb340ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: qubidt <qubidt at gmail dot com>
+
+pkgname=highlight-stderr
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Run a command and highlight its stderr, preserving the order of stdout and stderr "
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/joshtriplett/highlight-stderr"
+license=('MIT')
+depends=('glibc' 'gcc-libs')
+makedepends=('cargo')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
+sha512sums=('SKIP')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ cargo fetch --locked --target "${CARCH}-unknown-linux-gnu"
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --frozen
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm 755 -t "${pkgdir}/usr/bin" "target/release/${pkgname}"
+ install -Dm 644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
+}