summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2017-08-05 22:23:32 +0200
committerChristian Krause2017-08-05 22:23:32 +0200
commit068c85b8576a62f3248ad1874a21541228594404 (patch)
treecbeed07f73e435cfa11dc7f6804194d54ac653a7
downloadaur-068c85b8576a62f3248ad1874a21541228594404.tar.gz
highlight-wookietreiber-0.0.1-1
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD24
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b147490000f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat Aug 5 20:20:06 UTC 2017
+pkgbase = highlight-wookietreiber
+ pkgdesc = searches for a pattern or regular expression (regex) and highlights matches
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/wookietreiber/highlight
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = clang
+ makedepends = sbt
+ depends = gc
+ depends = libunwind
+ depends = re2
+ conflicts = hl-git
+ source = highlight-wookietreiber-0.0.1.tar.gz::https://github.com/wookietreiber/highlight/archive/v0.0.1.tar.gz
+ md5sums = 949b0e87e544819bfebf01d24d12dec3
+
+pkgname = highlight-wookietreiber
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..42ab3cf03f2d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..158e38bc9958
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
+
+pkgname=highlight-wookietreiber
+_pkgname=highlight
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="searches for a pattern or regular expression (regex) and highlights matches"
+arch=('i686' 'x86_64')
+url="https://github.com/wookietreiber/highlight"
+license=('GPL')
+depends=('gc' 'libunwind' 're2')
+makedepends=('clang' 'sbt')
+conflicts=('hl-git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/wookietreiber/highlight/archive/v$pkgver.tar.gz")
+md5sums=('949b0e87e544819bfebf01d24d12dec3')
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+
+ PREFIX=$pkgdir/usr sbt \
+ -ivy /tmp/makepkg-sbt-highlight/ivy2 \
+ -sbt-dir /tmp/makepkg-sbt-highlight/sbt \
+ install
+}