summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-09-14 13:59:14 -0400
committerGuillaume Horel2020-09-14 13:59:14 -0400
commitead8f5506997fecfdcf3a68fd93ba25f6ed35990 (patch)
tree750a9efb0b4f2ec82beaa767405884f632a143ab
parentea7e1f031eb93c9591f87139968eb4588b9cd482 (diff)
downloadaur-ead8f5506997fecfdcf3a68fd93ba25f6ed35990.tar.gz
fix version
also install man page
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 752334e8b5c4..f35113b21989 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = highwayhash
pkgdesc = Fast strong hash functions: SipHash/HighwayHash
- pkgver = 1.1
+ pkgver = 20190504.ea7e1f0
pkgrel = 1
url = https://github.com/google/highwayhash
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 22001ce5d6de..aeefc13f16eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=('highwayhash')
-pkgver='1.1'
+pkgver=20190504.ea7e1f0
pkgrel=1
pkgdesc="Fast strong hash functions: SipHash/HighwayHash"
url="https://github.com/google/highwayhash"
@@ -12,6 +12,10 @@ arch=('x86_64')
source=("git+https://github.com/google/highwayhash.git")
sha256sums=('SKIP')
+pkgver() {
+ git log -1 --format=%cd.%h --date=short|tr -d -
+}
+
build() {
cd "${srcdir}/${pkgname}"
make
@@ -20,4 +24,6 @@ build() {
package() {
cd "${srcdir}/${pkgname}"
make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -d "$pkgdir/usr/share/man/man3"
+ gzip -c highwayhash.3 > "$pkgdir/usr/share/man/man3/highwayhash.3.gz"
}