summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2018-04-12 12:52:04 -0400
committerGuillaume Horel2018-04-12 12:52:04 -0400
commitfe80021a6f2926b152a29ec25305821fc8641048 (patch)
treef8368a84790c492c9c43ae0416b63d77604e8c0e
downloadaur-fe80021a6f2926b152a29ec25305821fc8641048.tar.gz
initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ff2816da9ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = highwayhash
+ pkgdesc = Fast strong hash functions: SipHash/HighwayHash
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/google/farmhash
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ depends = gcc-libs
+ source = git+https://github.com/google/highwayhash.git
+ sha256sums = SKIP
+
+pkgname = highwayhash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eabdeecb0ab2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('highwayhash')
+pkgver='1.1'
+pkgrel=1
+pkgdesc="Fast strong hash functions: SipHash/HighwayHash"
+url="https://github.com/google/farmhash"
+depends=('gcc-libs')
+makedepends=('git')
+checkdepends=()
+license=('Apache')
+arch=('x86_64')
+source=("git+https://github.com/google/highwayhash.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" INCDIR="usr/include" LIBDIR="usr/lib" install
+}