summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormsojocs2022-05-13 15:23:57 +0800
committermsojocs2022-05-13 15:23:57 +0800
commit02f8a7c1bd69c90ade2a4e747f04b76ad77cd564 (patch)
treeacfec451764d402e52b74d5604f98417add1a8ac
parent38f585629cc448ffff0c18868c2a1d00c09d5409 (diff)
downloadaur-02f8a7c1bd69c90ade2a4e747f04b76ad77cd564.tar.gz
fix: 7z依赖
加强校验
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
-rw-r--r--hikari-field-client2
3 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 102f7caed295..1e4e6213b6b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,18 +4,19 @@ pkgbase = hikari-field-client-bin
pkgrel = 1
epoch = 1
url = https://store.hikarifield.co.jp/client
- arch = x86_64
+ arch = any
license = unknown
makedepends = asar
+ makedepends = p7zip
depends = electron13
options = !strip
source = HIKARI-FIELD-CLIENT-Setup-1.1.1.zip::https://client.hikarifield.co.jp/release/HIKARI-FIELD-CLIENT-Setup-1.1.1.zip
source = hikari-field-client.desktop
source = hikari-field-client.svg
source = hikari-field-client
- md5sums = 62486f9270ead23f2bbbe20a1dcd524d
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ sha256sums = b98f2aec774559d20f71da5bd3ac2dfaddd955df6947b44dc3500d4a52e5b86d
+ sha256sums = 2b556b725ae33587fc5ac1d53f1ab586b5f9c089dd765d9875e0c6c3971a4f55
+ sha256sums = 3a574b7d3bcfe2e4fbaacfd16a3b43dafae7decbc2f0030c56104cfbbbf75c7e
+ sha256sums = b8a71c44ec6dc48b00e0f53fc9482b449464e98dd87d5a3218fba01a9336ffbe
pkgname = hikari-field-client-bin
diff --git a/PKGBUILD b/PKGBUILD
index 08f80a53bfb8..f8ce9a8e70d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_hf_ver="1.1.1"
_hf_url="https://client.hikarifield.co.jp/release/HIKARI-FIELD-CLIENT-Setup-${_hf_ver}.zip"
-_hf_md5="62486f9270ead23f2bbbe20a1dcd524d"
+_hf_sha265="b98f2aec774559d20f71da5bd3ac2dfaddd955df6947b44dc3500d4a52e5b86d"
pkgname=hikari-field-client-bin
pkgver="${_hf_ver}" # 主版本号
@@ -10,25 +10,23 @@ pkgrel=1 # 修订版本号release
epoch=1 # 大版本迭代强制更新(维护者变更,尽量不用)
pkgdesc="Hikari Field Client For Linux. "
-arch=("x86_64")
+arch=("any")
url="https://store.hikarifield.co.jp/client"
license=('unknown')
depends=('electron13')
-makedepends=('asar')
+makedepends=('asar' 'p7zip')
source=(
"HIKARI-FIELD-CLIENT-Setup-${_hf_ver}.zip::${_hf_url}"
"hikari-field-client.desktop"
"hikari-field-client.svg"
"hikari-field-client"
)
-md5sums=(
- "${_hf_md5}"
- "SKIP" # desktop
- "SKIP" # svg
- "SKIP" # hikari-field-client
-)
+sha256sums=('b98f2aec774559d20f71da5bd3ac2dfaddd955df6947b44dc3500d4a52e5b86d'
+ '2b556b725ae33587fc5ac1d53f1ab586b5f9c089dd765d9875e0c6c3971a4f55'
+ '3a574b7d3bcfe2e4fbaacfd16a3b43dafae7decbc2f0030c56104cfbbbf75c7e'
+ 'b8a71c44ec6dc48b00e0f53fc9482b449464e98dd87d5a3218fba01a9336ffbe')
options=('!strip')
prepare(){
@@ -53,5 +51,5 @@ package(){
install -Dm644 "${srcdir}/hikari-field-client.desktop" "${pkgdir}/usr/share/applications/hikari-field-client.desktop"
install -Dm644 "${srcdir}/hikari-field-client.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/hikari-field-client.svg"
install -Dm755 "${srcdir}/hikari-field-client" "${pkgdir}/usr/bin/hikari-field-client"
- install -Dm644 "${srcdir}/tmp/hf/resources/app.asar" "${pkgdir}/opt/hikari-field-client/app.asar"
-} \ No newline at end of file
+ install -Dm644 "${srcdir}/tmp/hf/resources/app.asar" "${pkgdir}/usr/share/${pkgname}/app.asar"
+}
diff --git a/hikari-field-client b/hikari-field-client
index 3ab4e3501006..7d28ce21f1c4 100644
--- a/hikari-field-client
+++ b/hikari-field-client
@@ -1,2 +1,2 @@
#!/bin/bash
-electron13 /opt/hikari-field-client/app.asar \ No newline at end of file
+electron13 /usr/share/hikari-field-client-bin/app.asar \ No newline at end of file