summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-17 16:58:34 -0500
committerLuis Martinez2021-10-17 16:58:34 -0500
commit10236e6b0c5e1979977d610d12ba6754399d934c (patch)
treef47c5e13419a153b261c0be4a4601db4acfd5ceb
parenta8c0be8facdc68629e1f650cf230e3d01057c4e9 (diff)
downloadaur-10236e6b0c5e1979977d610d12ba6754399d934c.tar.gz
fix package
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD37
2 files changed, 24 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 022e9c365c0c..e041164400ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hilbish
- pkgdesc = A shell written in Go and extended with Lua
+ pkgdesc = The flower shell for Lua users
pkgver = 0.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rosettea/hilbish
install = hilbish.install
arch = x86_64
@@ -9,8 +9,9 @@ pkgbase = hilbish
license = MIT
makedepends = go>=1.16
depends = readline
- depends = lua51-lunacolors-git
- source = hilbish-0.5.1.tar.gz::https://github.com/rosettea/hilbish/archive/refs/tags/v0.5.1.tar.gz
+ depends = lua-lunacolors
+ options = !emptydirs
+ source = hilbish-0.5.1.tar.gz::https://github.com/rosettea/hilbish/archive/v0.5.1.tar.gz
sha256sums = 3fc4dca2662b9e50d55dce6beb96d1ddb1892d599b742efbc2f2190a7d858e36
pkgname = hilbish
diff --git a/PKGBUILD b/PKGBUILD
index 358c3ddbfabf..22e0fffac7ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,38 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=hilbish
pkgver=0.5.1
-pkgrel=1
-pkgdesc="A shell written in Go and extended with Lua"
+pkgrel=2
+pkgdesc="The flower shell for Lua users"
arch=('x86_64' 'aarch64')
url="https://github.com/rosettea/hilbish"
license=('MIT')
-depends=('readline' 'lua51-lunacolors-git')
+depends=('readline' 'lua-lunacolors')
makedepends=('go>=1.16')
install="$pkgname.install"
-source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+options=('!emptydirs')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('3fc4dca2662b9e50d55dce6beb96d1ddb1892d599b742efbc2f2190a7d858e36')
prepare() {
- cd "Hilbish-$pkgver"
- sed -i '\|/etc/shells|d' Makefile
+ cd "Hilbish-$pkgver"
+ sed -i '\|/etc/shells|d' Makefile
}
build() {
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- cd "Hilbish-$pkgver"
- make build
+ cd "Hilbish-$pkgver"
+ make build
}
package() {
- cd "Hilbish-$pkgver"
- DESTDIR="$pkgdir/" make install
- install -Dm 444 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm 444 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ cd "Hilbish-$pkgver"
+ DESTDIR="$pkgdir/" make install
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}