summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-03-22 21:31:16 -0500
committerLuis Martinez2022-03-22 21:31:16 -0500
commit4a636bb436dfdb2d0d314b3dcfa7682c3545ac08 (patch)
tree81a7f25b5f3c92967c76f2ed407c459cf402caf2
parent2a7dbbf6e052ec6ffae19720cd1091df4cdc4ac7 (diff)
downloadaur-4a636bb436dfdb2d0d314b3dcfa7682c3545ac08.tar.gz
update to 1.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md27
-rw-r--r--PKGBUILD4
3 files changed, 26 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29e5f5535e04..e60d8bec86fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hilbish
pkgdesc = The flower shell for Lua users
- pkgver = 1.1.0
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/rosettea/hilbish
install = hilbish.install
@@ -14,7 +14,7 @@ pkgbase = hilbish
depends = lua-succulent
depends = lua-inspect
options = !emptydirs
- source = hilbish-1.1.0.tar.gz::https://github.com/rosettea/hilbish/archive/v1.1.0.tar.gz
- sha256sums = b86813a67428f45a2aec601871f4df53a3ca5bf8e6666d8ea76d799ce3c9a8fe
+ source = hilbish-1.2.0.tar.gz::https://github.com/rosettea/hilbish/archive/v1.2.0.tar.gz
+ sha256sums = e5bb77a90e05ee8ab063e4372919f58f6c6ccd341056750a581899ca193782a4
pkgname = hilbish
diff --git a/CHANGELOG.md b/CHANGELOG.md
index f76613888d62..563eb7ee293d 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,21 @@
# 🎀 Changelog
-## [1.1.0] - 2021-03-17
+## [1.2.0] - 2022-03-17
+### Added
+- Job Management additions
+ - `job.start` and `job.done` hooks (`doc hooks job`)
+ - `hilbish.jobs` interface (`get(id)` function gets a job object via `id`, `all()` gets all)
+- Customizable runner/exec mode
+ - However Hilbish runs interactive user input can now be changed Lua side (`doc runner-mode`)
+
+### Changed
+- `vimMode` doc is now `vim-mode`
+
+### Fixed
+- Make sure input which is supposed to go in history goes there
+- Cursor is right at the end of input on history search
+
+## [1.1.0] - 2022-03-17
### Added
- `hilbish.vimAction` hook (`doc vimMode actions`)
- `command.not-executable` hook (will replace `command.no-perm` in a future release)
@@ -16,26 +31,26 @@
- Fix removal of dot in the beginning of folders/files that have them for file complete
- Fix prompt being set to the continue prompt even when exited
-## [1.0.4] - 2021-03-12
+## [1.0.4] - 2022-03-12
### Fixed
- Panic when history directory doesn't exist
-## [1.0.3] - 2021-03-12
+## [1.0.3] - 2022-03-12
### Fixed
- Removed duplicate executable suggestions
- User input is added to history now instead of what's ran by Hilbish
- Formatting issue with prompt on no input
-## [1.0.2] - 2021-03-06
+## [1.0.2] - 2022-03-06
### Fixed
- Cases where Hilbish's history directory doesn't exist will no longer cause a panic
-## [1.0.1] - 2021-03-06
+## [1.0.1] - 2022-03-06
### Fixed
- Using `hilbish.appendPath` will no longer result in string spam (debugging thing left being)
- Prompt gets set properly on startup
-## [1.0.0] - 2021-03-06
+## [1.0.0] - 2022-03-06
### Added
- MacOS is now officialy supported, default compile time vars have been added
for it
diff --git a/PKGBUILD b/PKGBUILD
index 9b797521b457..c65893db599e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=hilbish
-pkgver=1.1.0
+pkgver=1.2.0
pkgrel=1
pkgdesc="The flower shell for Lua users"
arch=('x86_64' 'i686' 'aarch64')
@@ -13,7 +13,7 @@ install="$pkgname.install"
options=('!emptydirs')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('b86813a67428f45a2aec601871f4df53a3ca5bf8e6666d8ea76d799ce3c9a8fe')
+sha256sums=('e5bb77a90e05ee8ab063e4372919f58f6c6ccd341056750a581899ca193782a4')
prepare() {
cd "Hilbish-$pkgver"