summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-06-12 18:05:31 -0500
committerLuis Martinez2021-06-12 18:05:31 -0500
commit780f2b694ca854bab39e3f686fe8647d64d6b765 (patch)
tree415055d448386ab13c1c30e9f293206cab871627
parentbc3280f85893b92fa7c872d6db05e804afec8c77 (diff)
downloadaur-780f2b694ca854bab39e3f686fe8647d64d6b765.tar.gz
update to 0.5.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--hilbish.install4
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ee507b3a1d2..e6164c13d98c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = hilbish
pkgdesc = A shell written in Go and extended with Lua
- pkgver = 0.4.0
+ pkgver = 0.5.0
pkgrel = 1
- url = https://github.com/hilbis/hilbish
+ url = https://github.com/rosettea/hilbish
install = hilbish.install
arch = x86_64
arch = aarch64
@@ -11,8 +11,7 @@ pkgbase = hilbish
depends = readline
depends = lua51-lunacolors-git
optdepends = lua
- source = hilbish-0.4.0.tar.gz::https://github.com/hilbis/hilbish/archive/refs/tags/v0.4.0.tar.gz
- sha256sums = 5c6e9bc93df00c8225f34dfa51c5dc4f52f526d23b34785854fd6019a3e7d77e
+ source = hilbish-0.5.0.tar.gz::https://github.com/rosettea/hilbish/archive/refs/tags/v0.5.0.tar.gz
+ sha256sums = 4c0a5608445ea5fc5ee1c7db8825ea7e19e6363624d94e84523a11141f127ba3
pkgname = hilbish
-
diff --git a/PKGBUILD b/PKGBUILD
index c5bb0a793914..39e5bdaf5e8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
pkgname=hilbish
-pkgver=0.4.0
+pkgver=0.5.0
pkgrel=1
pkgdesc="A shell written in Go and extended with Lua"
arch=('x86_64' 'aarch64')
-url="https://github.com/hilbis/hilbish"
+url="https://github.com/rosettea/hilbish"
license=('MIT')
depends=('readline' 'lua51-lunacolors-git')
makedepends=('go>=1.16')
optdepends=('lua')
install="$pkgname.install"
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('5c6e9bc93df00c8225f34dfa51c5dc4f52f526d23b34785854fd6019a3e7d77e')
+sha256sums=('4c0a5608445ea5fc5ee1c7db8825ea7e19e6363624d94e84523a11141f127ba3')
prepare() {
- mv "Hilbish-$pkgver" "$pkgname-$pkgver"
- cd "$pkgname-$pkgver"
+ cd "Hilbish-$pkgver"
sed -i '\|/etc/shells|d' Makefile
}
@@ -27,12 +26,12 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- cd "$pkgname-$pkgver"
+ cd "Hilbish-$pkgver"
make build
}
package() {
- cd "$pkgname-$pkgver"
+ cd "Hilbish-$pkgver"
DESTDIR="$pkgdir/" make install
install -Dm 444 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm 444 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
diff --git a/hilbish.install b/hilbish.install
index cbb25de224ba..7e4825f3d6f1 100644
--- a/hilbish.install
+++ b/hilbish.install
@@ -1,4 +1,5 @@
post_install() {
+ echo ":: Adding hilbish to /etc/shells..."
grep -qe '^/usr/bin/hilbish$' /etc/shells || echo '/usr/bin/hilbish' >> /etc/shells
}
@@ -7,5 +8,6 @@ post_upgrade() {
}
pre_remove() {
+ echo ":: Removing hilbish from /etc/shells..."
sed -ri -e '\|^/usr/bin/hilbish$|d' /etc/shells
-} \ No newline at end of file
+}