summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-03-24 19:16:18 -0500
committerlmartinez-mirror2021-03-24 19:16:18 -0500
commitbb1b3474edf9df4e09eb0d99e69060fb1ffa69ed (patch)
tree9452b5c3e0a241b1f688b3a1a10b8b6a3185e6bd
downloadaur-bb1b3474edf9df4e09eb0d99e69060fb1ffa69ed.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9db7ef2828ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hilbish
+ pkgdesc = A shell written in Go and extended with Lua
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/hilbis/hilbish
+ arch = x86_64
+ license = MIT
+ makedepends = go>=1.16
+ depends = readline
+ optdepends = lua
+ source = hilbish-0.1.2.tar.gz::https://github.com/hilbis/hilbish/archive/refs/tags/v0.1.2.tar.gz
+ sha256sums = 435496b0a3f6e59c17efaa74fe5ccb7161296ca906b82030da63e0c8509313f8
+
+pkgname = hilbish
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..193ecd4835e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: lmartinez-mirror
+pkgname=hilbish
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="A shell written in Go and extended with Lua"
+arch=('x86_64')
+url="https://github.com/hilbis/hilbish"
+license=('MIT')
+depends=('readline')
+makedepends=('go>=1.16')
+optdepends=('lua')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('435496b0a3f6e59c17efaa74fe5ccb7161296ca906b82030da63e0c8509313f8')
+
+prepare() {
+ mv "Hilbish-$pkgver" "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
+ sed -i "s|/usr|$pkgdir/usr|" Makefile
+}
+
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "$pkgname-$pkgver"
+ make build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install
+ install -Dm 444 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 444 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+} \ No newline at end of file