summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-04-17 22:31:19 -0500
committerLuis Martinez2023-04-17 22:31:19 -0500
commitd469e514e71bd942af46c6ce2959362316292335 (patch)
tree9611a322e48d0f35dad4410922f7a0ca8694566b
parenta0d82e75380e5a96fc379567be1957baaea3152b (diff)
downloadaur-d469e514e71bd942af46c6ce2959362316292335.tar.gz
update to 2.1.2
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG.md29
-rw-r--r--PKGBUILD23
3 files changed, 49 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be8de70d4c75..37171439c4e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hilbish
pkgdesc = The flower shell for Lua users
- pkgver = 2.0.1
+ pkgver = 2.1.2
pkgrel = 1
url = https://github.com/rosettea/hilbish
install = hilbish.install
@@ -9,12 +9,14 @@ pkgbase = hilbish
arch = i686
arch = aarch64
license = MIT
+ makedepends = git
makedepends = go
depends = lua-lunacolors
depends = lua-succulent
depends = lua-inspect
options = !emptydirs
- source = hilbish-2.0.1.tar.gz::https://github.com/rosettea/hilbish/archive/v2.0.1.tar.gz
- sha256sums = 9adb3ed5efd4f4c5719f152379a7fa081bfcb563f2edea3b90162a49f20b32e2
+ source = hilbish::git+https://github.com/rosettea/hilbish#commit=5541e22?signed
+ validpgpkeys = 784DF7A14968C5094E16839C904FC49417B44DCD
+ sha256sums = SKIP
pkgname = hilbish
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 6f80bb6adf30..474999e6cd9b 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,33 @@
# 🎀 Changelog
+## [2.1.2] - 2022-04-10
+### Removed
+- Bad april fools code ;(
+
+## [2.1.1] - 2022-04-01
+### Added
+- Validation checks for command input
+- Improved runtime performance
+- Validate Lua code
+
+## [2.1.0] - 2022-02-10
+### Added
+- Documented custom userdata types (Job and Timer Objects)
+ - Coming with this fix is also adding the return types for some functions that were missing it
+- Added a dedicated input and dedicated outputs for commanders (sinks - info at `doc api commander`).
+- Local docs is used if one of Hilbish's branches is found
+- Return 1 exit code on doc not found
+- `hilbish.runner.getCurrent()` to get the current runner
+- Initialize Hilbish Lua API before handling signals
+
+### Fixed
+- `index` or `_index` subdocs should not show up anymore
+- `hilbish.which` not working correctly with aliases
+- Commanders not being able to pipe with commands or any related operator.
+- Resolve symlinks in completions
+- Updated `runner-mode` docs
+- Fix `hilbish.completion` functions panicking when empty input is provided
+
## [2.0.1] - 2022-12-28
### Fixed
- Corrected documentation for hooks, removing outdated `command.no-perm`
@@ -617,6 +645,7 @@ This input for example will prompt for more input to complete:
First "stable" release of Hilbish.
+[2.1.0]: https://github.com/Rosettea/Hilbish/compare/v2.0.1...v2.1.0
[2.0.1]: https://github.com/Rosettea/Hilbish/compare/v2.0.0...v2.0.1
[2.0.0]: https://github.com/Rosettea/Hilbish/compare/v1.2.0...v2.0.0
[2.0.0-rc1]: https://github.com/Rosettea/Hilbish/compare/v1.2.0...v2.0.0-rc1
diff --git a/PKGBUILD b/PKGBUILD
index 84a3cfab6d14..565d88a6ca9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,29 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+## GPG Keys: 784DF7A14968C5094E16839C904FC49417B44DCD
+## Get from the Ubuntu keyserver
+## gpg --keyserver keyserver.ubuntu.com --recv-keys 784DF7A14968C5094E16839C904FC49417B44DCD
+
pkgname=hilbish
-pkgver=2.0.1
+pkgver=2.1.2
pkgrel=1
+_commit=5541e22
pkgdesc="The flower shell for Lua users"
arch=('x86_64' 'i686' 'aarch64')
url="https://github.com/rosettea/hilbish"
license=('MIT')
depends=('lua-lunacolors' 'lua-succulent' 'lua-inspect')
-makedepends=('go')
+makedepends=('git' 'go')
install="$pkgname.install"
options=('!emptydirs')
changelog=CHANGELOG.md
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('9adb3ed5efd4f4c5719f152379a7fa081bfcb563f2edea3b90162a49f20b32e2')
+# source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$pkgname::git+$url#commit=$_commit?signed")
+sha256sums=('SKIP')
+validpgpkeys=('784DF7A14968C5094E16839C904FC49417B44DCD') ## sammyette
prepare() {
- cd "Hilbish-$pkgver"
+ cd "$pkgname"
go mod download
}
@@ -27,18 +34,18 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
- cd "Hilbish-$pkgver"
+ cd "$pkgname"
go build -ldflags "-linkmode=external -X main.dataDir=/usr/share/hilbish"
}
check() {
- cd "Hilbish-$pkgver"
+ cd "$pkgname"
go test ./...
}
package() {
## do not use the taskfile, install everything manually
- cd "Hilbish-$pkgver"
+ cd "$pkgname"
install -Dv "$pkgname" -t "$pkgdir/usr/bin/"
install -dv "$pkgdir/usr/share/hilbish/"
cp -av libs docs emmyLuaDocs nature .hilbishrc.lua "$pkgdir/usr/share/hilbish/"