summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBangduo Chen2021-01-01 22:38:52 +0800
committerBangduo Chen2021-01-01 22:38:52 +0800
commit651bebfc86fc9a7208aea7ddcfcd9d3131455e44 (patch)
tree6820ef0173f5600a9c68b53bd61572465c1f5871
downloadaur-651bebfc86fc9a7208aea7ddcfcd9d3131455e44.tar.gz
upload hillstone VPN
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6605c8b54837
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = hillstone-vpn
+ pkgdesc = The Hillstone Secure Connect VPN client for Linux.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://docs.hillstonenet.com/en/Content/7_VPN/SSL_VPN_Client_L.htm#
+ arch = x86_64
+ license = unknown
+ source = https://github.com/JackMoriarty/HillstoneVPN/releases/download/v1.0.0/HillstoneVPN-1.0.0.tar.gz
+ md5sums = bb0301e31bdaf7c6bcbafae8e74cd3d6
+
+pkgname = hillstone-vpn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d7511a76128
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Bangduo Chen <1413563527@qq.com>
+# Contributor: Bangduo Chen <1413563527@qq.com>
+pkgname=hillstone-vpn
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="The Hillstone Secure Connect VPN client for Linux. "
+arch=(x86_64)
+url="http://docs.hillstonenet.com/en/Content/7_VPN/SSL_VPN_Client_L.htm#"
+license=('unknown')
+changelog=
+source=("https://github.com/JackMoriarty/HillstoneVPN/releases/download/v1.0.0/HillstoneVPN-$pkgver.tar.gz")
+md5sums=('bb0301e31bdaf7c6bcbafae8e74cd3d6')
+
+package() {
+ tar -zxvf "HillstoneVPN-$pkgver.tar.gz" -C "${srcdir}"
+
+ install -d "${pkgdir}/opt"
+ cp -r "${srcdir}/$HillstoneVPN" "${pkgdir}/opt"
+
+ install -d "${pkgdir}/usr/share/applications"
+ install -Dm755 "${srcdir}/HillstoneVPN/HillstoneVPN.desktop" "${pkgdir}/usr/share/applications"
+}