summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-11-02 17:20:30 -0500
committeracxz2020-11-02 17:20:30 -0500
commitdc338ef69d22d3c82994ac2ca935cdc95f48622b (patch)
tree20f8ebcbba52f3b09e8f1b5b2aea90870e431592
parentc1b2e786efe180ed5d11b6ea773166bd12f3ca19 (diff)
downloadaur-dc338ef69d22d3c82994ac2ca935cdc95f48622b.tar.gz
[hip-nvcc] updpkg 3.9.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--hipinfo.patch28
3 files changed, 20 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eadf38aa4049..d1f1c4021621 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hip-nvcc
pkgdesc = Heterogeneous Interface for Portability ROCm
- pkgver = 3.7.0
+ pkgver = 3.9.0
pkgrel = 1
url = https://github.com/ROCm-Developer-Tools/HIP
arch = x86_64
@@ -11,10 +11,10 @@ pkgbase = hip-nvcc
depends = llvm-amdgpu
provides = hip
conflicts = hip
- source = hip-nvcc-3.7.0.tar.gz::https://github.com/ROCm-Developer-Tools/HIP/archive/rocm-3.7.0.tar.gz
+ source = hip-nvcc-3.9.0.tar.gz::https://github.com/ROCm-Developer-Tools/HIP/archive/rocm-3.9.0.tar.gz
source = hipinfo.patch
- sha256sums = 757b392c3beb29beea27640832fbad86681dbd585284c19a4c2053891673babd
- sha256sums = f94d8b2426d5f8eecd420698a2b7f3d66ddc0531afe313a572f0b644f6e45b64
+ sha256sums = 25ad58691456de7fd9e985629d0ed775ba36a2a0e0b21c086bd96ba2fb0f7ed1
+ sha256sums = bddced0c770848aaa44514986fed3fe1c01699dffe41d11767a5014f0ebfa69f
pkgname = hip-nvcc
diff --git a/PKGBUILD b/PKGBUILD
index 787b0fa3e4c2..167f5b6157dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=hip-nvcc
-pkgver=3.7.0
+pkgver=3.9.0
pkgrel=1
pkgdesc="Heterogeneous Interface for Portability ROCm"
arch=('x86_64')
@@ -13,8 +13,8 @@ conflicts=('hip')
_git='https://github.com/ROCm-Developer-Tools/HIP'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz"
"hipinfo.patch")
-sha256sums=('757b392c3beb29beea27640832fbad86681dbd585284c19a4c2053891673babd'
- 'f94d8b2426d5f8eecd420698a2b7f3d66ddc0531afe313a572f0b644f6e45b64')
+sha256sums=('25ad58691456de7fd9e985629d0ed775ba36a2a0e0b21c086bd96ba2fb0f7ed1'
+ 'bddced0c770848aaa44514986fed3fe1c01699dffe41d11767a5014f0ebfa69f')
prepare() {
cd "${srcdir}/HIP-rocm-$pkgver"
diff --git a/hipinfo.patch b/hipinfo.patch
index 910b17afdc1d..1f3a280008f9 100644
--- a/hipinfo.patch
+++ b/hipinfo.patch
@@ -1,7 +1,7 @@
-diff --unified --recursive --text HIP-rocm-3.5.1/bin/hipconfig HIP-rocm-3.5.1.new/bin/hipconfig
---- HIP-rocm-3.5.1/bin/hipconfig 2020-06-16 11:44:26.000000000 -0400
-+++ HIP-rocm-3.5.1.new/bin/hipconfig 2020-06-22 20:44:28.932530458 -0400
-@@ -96,12 +96,12 @@
+diff --unified --recursive --text HIP-rocm-3.9.0/bin/hipconfig HIP-rocm-3.9.0.new/bin/hipconfig
+--- HIP-rocm-3.9.0/bin/hipconfig 2020-10-13 02:42:39.000000000 -0400
++++ HIP-rocm-3.9.0.new/bin/hipconfig 2020-11-02 17:13:56.119076102 -0500
+@@ -98,12 +98,12 @@
$HIP_INFO_PATH= "$HIP_PATH/lib/.hipInfo"; # use actual file
}
#---
@@ -16,10 +16,10 @@ diff --unified --recursive --text HIP-rocm-3.5.1/bin/hipconfig HIP-rocm-3.5.1.ne
$HIP_COMPILER = $ENV{'HIP_COMPILER'} // $hipInfo{'HIP_COMPILER'} // "hcc";
$HIP_RUNTIME = $ENV{'HIP_RUNTIME'} // $hipInfo{'HIP_RUNTIME'} // "HCC";
-diff --unified --recursive --text HIP-rocm-3.5.1/CMakeLists.txt HIP-rocm-3.5.1.new/CMakeLists.txt
---- HIP-rocm-3.5.1/CMakeLists.txt 2020-06-16 11:44:26.000000000 -0400
-+++ HIP-rocm-3.5.1.new/CMakeLists.txt 2020-06-22 20:43:27.635570691 -0400
-@@ -106,6 +106,7 @@
+diff --unified --recursive --text HIP-rocm-3.9.0/CMakeLists.txt HIP-rocm-3.9.0.new/CMakeLists.txt
+--- HIP-rocm-3.9.0/CMakeLists.txt 2020-10-13 02:42:39.000000000 -0400
++++ HIP-rocm-3.9.0.new/CMakeLists.txt 2020-11-02 17:12:49.638464570 -0500
+@@ -138,6 +138,7 @@
endif()
endif()
message(STATUS "HIP Platform: " ${HIP_PLATFORM})
@@ -27,7 +27,7 @@ diff --unified --recursive --text HIP-rocm-3.5.1/CMakeLists.txt HIP-rocm-3.5.1.n
# Determine HIP_COMPILER
# Either hcc or clang; default is hcc
-@@ -300,7 +301,6 @@
+@@ -332,7 +333,6 @@
include_directories(${PROJECT_SOURCE_DIR}/include)
add_subdirectory(rocclr)
@@ -35,7 +35,7 @@ diff --unified --recursive --text HIP-rocm-3.5.1/CMakeLists.txt HIP-rocm-3.5.1.n
# set(ROCclr_CXX_FLAGS "-hc -fno-gpu-rdc --amdgpu-target=gfx803 --amdgpu-target=gfx900 --amdgpu-target=gfx906 --amdgpu-target=gfx908 ")
-@@ -404,14 +404,15 @@
+@@ -436,14 +436,14 @@
else()
target_link_libraries(device INTERFACE host)
endif()
@@ -47,22 +47,20 @@ diff --unified --recursive --text HIP-rocm-3.5.1/CMakeLists.txt HIP-rocm-3.5.1.n
if(HIP_PLATFORM STREQUAL "hcc" OR HIP_PLATFORM STREQUAL "rocclr")
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lpl_ca)
endif()
-+
+# Generate .hipInfo
+file(WRITE "${PROJECT_BINARY_DIR}/.hipInfo" ${_buildInfo})
+
# Generate .hipVersion
file(WRITE "${PROJECT_BINARY_DIR}/.hipVersion" ${_versionInfo})
-@@ -445,11 +446,6 @@
+@@ -482,9 +482,7 @@
endif()
# Install .hipInfo
-if(HIP_PLATFORM STREQUAL "hcc" OR HIP_PLATFORM STREQUAL "rocclr")
- install(FILES ${PROJECT_BINARY_DIR}/.hipInfo DESTINATION lib)
-endif()
--
--# Install .hipInfo
- install(FILES ${PROJECT_BINARY_DIR}/.hipInfo DESTINATION lib)
++install(FILES ${PROJECT_BINARY_DIR}/.hipInfo DESTINATION lib)
# Install .hipVersion
+ install(FILES ${PROJECT_BINARY_DIR}/.hipVersion DESTINATION bin)