summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2020-03-03 23:55:45 -0500
committerneeshy2020-03-07 14:29:30 -0500
commit996a144e90850b78ad7a7b6f0dfd718e254ecdc0 (patch)
tree1f770f2331d4a2030a348720425ae8144b4084d9
parent13a1195506b0d47db51b14dc6f695ab348331265 (diff)
downloadaur-996a144e90850b78ad7a7b6f0dfd718e254ecdc0.tar.gz
Cleanup
Consistent style across project Remove extraneous dependencies Update packages Update checksums and .SRCINFO Specify proper license Fix prefixes Prefer make to ninja Much more TODO: miopen, rocm-cmake{,-git}, rock-dkms{,-git}, Remove duplicates in makedepends and depends git submodules
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD67
2 files changed, 36 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d5a5bbe357d..3165fa89ac71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
pkgbase = hipblas
pkgdesc = Next generation BLAS implementation for ROCm platform
- pkgver = 3.0.0
+ pkgver = 3.1.0
pkgrel = 1
url = https://github.com/ROCmSoftwarePlatform/hipBLAS
arch = x86_64
- license = NCSAOSL
- makedepends = git
+ license = custom:NCSAOSL
makedepends = cmake
- makedepends = gcc
- makedepends = ninja
- makedepends = hcc>=3.0.0
+ makedepends = hcc>=3.1.0
makedepends = python2
- makedepends = rocm-comgr>=3.0.0
+ makedepends = rocm-comgr>=3.1.0
makedepends = rocminfo
depends = hcc
depends = hip
- source = https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-3.0.tar.gz
+ source = https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-3.1.tar.gz
source = hipblas_hsa.patch
- sha256sums = 94dbe6d9b451ce80b407726353816415f5aee346547de5d3917aa5dfc5634323
- sha256sums = SKIP
+ sha256sums = c7962f7ec775028cfede65f09f9b7b1774009ccf5e3744c8604ab2a2c84f027e
+ sha256sums = d5206ce084f065f860ba1b1f9dc860c1500d9d4cc0b92473e1072ad819e8148d
pkgname = hipblas
diff --git a/PKGBUILD b/PKGBUILD
index e9364f8f4b2b..2166d5b69b0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,65 +1,56 @@
# Maintainer: Markus Näther <naether.markus@gmail.com>
pkgname=hipblas
-pkgver=3.0.0
+_pkgver=3.1
+pkgver="$_pkgver.0"
pkgrel=1
pkgdesc="Next generation BLAS implementation for ROCm platform"
arch=('x86_64')
url="https://github.com/ROCmSoftwarePlatform/hipBLAS"
-license=('NCSAOSL')
-depends=(hcc hip)
-makedepends=(git cmake gcc ninja "hcc>=${pkgver}" python2 "rocm-comgr>=${pkgver}" rocminfo)
-srcver="3.0"
-source=(
- "https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-$srcver.tar.gz"
- "hipblas_hsa.patch"
- )
-sha256sums=(
- "94dbe6d9b451ce80b407726353816415f5aee346547de5d3917aa5dfc5634323"
- 'SKIP'
- )
+license=('custom:NCSAOSL')
+depends=('hcc' 'hip')
+makedepends=('cmake' "hcc>=$pkgver" 'python2' "rocm-comgr>=$pkgver" 'rocminfo')
+source=("https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-$_pkgver.tar.gz"
+ "hipblas_hsa.patch")
+sha256sums=('c7962f7ec775028cfede65f09f9b7b1774009ccf5e3744c8604ab2a2c84f027e'
+ 'd5206ce084f065f860ba1b1f9dc860c1500d9d4cc0b92473e1072ad819e8148d')
prepare() {
- cd "${srcdir}/hipBLAS-rocm-$srcver"
- patch --forward --strip=1 --input="${srcdir}/hipblas_hsa.patch"
+ cd "$srcdir/hipBLAS-rocm-$_pkgver"
+ patch -Np1 -i "$srcdir/hipblas_hsa.patch"
}
build() {
mkdir -p "$srcdir/build"
cd "$srcdir/build"
- # Tensile library needs python to be python2
- #export PATH="$srcdir:$PATH"
- #[[ -e "$srcdir/python" ]] || ln -s /usr/bin/python2 "$srcdir/python"
-
# fix broken build with stack protection
- export CXXFLAGS=$(echo $CXXFLAGS | sed -e 's/-fstack-protector-strong//')
- export CFLAGS=$(echo $CFLAGS | sed -e 's/-fstack-protector-strong//')
- export CPPFLAGS=$(echo $CPPFLAGS | sed -e 's/-fstack-protector-strong//')
+ export CFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CFLAGS")"
+ export CXXFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CXXFLAGS")"
+ export CPPFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CPPFLAGS")"
# compile with HCC
- export CXX=/opt/rocm/hcc/bin/hcc
-
- #patch --forward --strip=1 --input="hipsparse_hsa.patch"
+ export CXX="/opt/rocm/hcc/bin/hcc"
# TODO: fix librocblas.so, it contains references to $srcdir
cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="$pkgdir/opt/rocm/hipblas" \
- -Dhip_DIR="/opt/rocm/hip/lib/cmake/hip" \
- -Dhcc_DIR="/opt/rocm/hcc/lib/cmake/hcc" \
- -Damd_comgr_DIR="/opt/rocm/lib/cmake/amd_comgr" \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm/hipblas \
+ -Dhip_DIR=/opt/rocm/hip/lib/cmake/hip \
+ -Dhcc_DIR=/opt/rocm/hcc/lib/cmake/hcc \
+ -Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
-DBUILD_CLIENTS_SAMPLES=OFF \
-DBUILD_CLIENTS_TESTS=OFF \
- -DHSA_PATH="/opt/rocm/hsa" \
- -G "Ninja" \
- "$srcdir/hipBLAS-rocm-$srcver"
- ninja
+ -DHSA_PATH=/opt/rocm/hsa \
+ "$srcdir/hipBLAS-rocm-$_pkgver"
+ make
}
package() {
- ninja -C "$srcdir/build" install
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir" install
- mkdir -p $pkgdir/etc/ld.so.conf.d
- cat <<-EOF > $pkgdir/etc/ld.so.conf.d/hipblas.conf
- /opt/rocm/hipblas/lib/
- EOF
+ install -d "$pkgdir/etc/ld.so.conf.d"
+ cat << EOF > "$pkgdir/etc/ld.so.conf.d/hipblas.conf"
+/opt/rocm/hipblas/lib
+EOF
}