summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2020-03-10 19:59:01 +0000
committerneeshy2020-03-10 19:59:01 +0000
commit0984789cc8a2075e7524da66c5a61ed4538f02b3 (patch)
treebd27308783a1dfdd7ee274b7dd3d0f79d6f0ab02
parent5fcf403fdefddff7dc33a030b4683820a9993c2d (diff)
downloadaur-0984789cc8a2075e7524da66c5a61ed4538f02b3.tar.gz
Fix various bugs
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 876c38450c12..a16b44b7e8bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = hipcub
makedepends = cmake
makedepends = python2
makedepends = rocminfo
+ makedepends = rocm-comgr
depends = hcc
depends = hip
source = https://github.com/ROCmSoftwarePlatform/hipCUB/archive/3.1.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 49ed02fb16a6..081280c22198 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ arch=('x86_64')
url="https://github.com/ROCmSoftwarePlatform/hipCUB"
license=('custom:NCSAOSL')
depends=('hcc' 'hip')
-makedepends=('cmake' 'python2' 'rocminfo')
+makedepends=('cmake' 'python2' 'rocminfo' 'rocm-comgr')
source=("https://github.com/ROCmSoftwarePlatform/hipCUB/archive/$pkgver.tar.gz")
sha256sums=('9fa41d9b25d5347ea6446ef32777dbe447257ccb494d82cb134529f4b45064a0')
@@ -30,6 +30,7 @@ build() {
# TODO: fix libhipcub.so, it contains references to $srcdir
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/opt/rocm/hipcub \
+ -Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
"$srcdir/hipCUB-$pkgver"
make
}