summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaetherm2019-06-12 18:21:18 +0200
committernaetherm2019-06-12 18:21:18 +0200
commit1c3bb24fcbb84610e9e057ac7a3188be9703b94c (patch)
tree92bf0c05a14e236e0c73248cc25b0488804179e9
downloadaur-1c3bb24fcbb84610e9e057ac7a3188be9703b94c.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD46
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2499d7b0ade5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = hipcub
+ pkgdesc = Reusable software components for the rocm developers.
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = https://github.com/ROCmSoftwarePlatform/hipCUB
+ arch = x86_64
+ license = NCSAOSL
+ makedepends = git
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = ninja
+ makedepends = hcc
+ makedepends = python2
+ makedepends = rocminfo
+ depends = hcc
+ depends = hip
+ source = https://github.com/ROCmSoftwarePlatform/hipCUB/archive/2.5.0.tar.gz
+ sha256sums = 5b0990d202ce191bef312ec6d06868cabae273b48d08b9026c88f879a43583ab
+
+pkgname = hipcub
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1681e6c9bc93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
+pkgname=hipcub
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="Reusable software components for the rocm developers."
+arch=('x86_64')
+url="https://github.com/ROCmSoftwarePlatform/hipCUB"
+license=('NCSAOSL')
+depends=(hcc hip)
+makedepends=(git cmake gcc ninja hcc python2 rocminfo)
+srcver="2.5.0"
+source=("https://github.com/ROCmSoftwarePlatform/hipCUB/archive/$srcver.tar.gz")
+sha256sums=("5b0990d202ce191bef312ec6d06868cabae273b48d08b9026c88f879a43583ab")
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ # Tensile library needs python to be python2
+ export PATH="$srcdir:$PATH"
+ [[ -e "$srcdir/python" ]] || ln -s /usr/bin/python2 "$srcdir/python"
+
+ # fix broken build with stack protection
+ export CXXFLAGS=$(echo $CXXFLAGS | sed -e 's/-fstack-protector-strong//')
+ export CFLAGS=$(echo $CFLAGS | sed -e 's/-fstack-protector-strong//')
+ export CPPFLAGS=$(echo $CPPFLAGS | sed -e 's/-fstack-protector-strong//')
+
+ # compile with HCC
+ export CXX=/opt/rocm/hcc/bin/hcc
+
+ # TODO: fix libhipcub.so, it contains references to $srcdir
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="$pkgdir/opt/rocm/hipcub" \
+ -G Ninja \
+ "$srcdir/hipCUB-$srcver"
+ ninja
+}
+
+package() {
+ ninja -C "$srcdir/build" install
+
+ mkdir -p $pkgdir/etc/ld.so.conf.d
+ cat <<-EOF > $pkgdir/etc/ld.so.conf.d/hipcub.conf
+ /opt/rocm/hipcub/lib/
+ EOF
+}