summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2022-07-01 19:15:27 +0200
committerTorsten Keßler2022-07-01 19:15:27 +0200
commit411e0a7f72e6a66e81a8a0e14fe1a2b4dd985d1b (patch)
tree6b067684a28a0e2e9d0b512387305a2a6c4e036c
parent6ffc844801473f3fb03cb977a65f9bad2bea3450 (diff)
downloadaur-411e0a7f72e6a66e81a8a0e14fe1a2b4dd985d1b.tar.gz
upgpkg: hipcub 5.2.0-1
* Update checksum * Update links to official documentation
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2eb9824cfe8..e8a8661b0c0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = hipcub
pkgdesc = Header-only library on top of rocPRIM or CUB
- pkgver = 5.1.3
+ pkgver = 5.2.0
pkgrel = 1
- url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#hipcub
+ url = https://docs.amd.com/bundle/hipCUB-release-rocm-rel-5.2/page/introduction.html
arch = x86_64
license = custom
makedepends = cmake
@@ -10,7 +10,7 @@ pkgbase = hipcub
makedepends = git
makedepends = hip
depends = rocprim
- source = hipcub-5.1.3.tar.gz::https://github.com/ROCmSoftwarePlatform/hipCUB/archive/rocm-5.1.3.tar.gz
- sha256sums = dc75640689b6a5e15dd3acea643266bdf114ea63efc60be8272f484cf8f04494
+ source = hipcub-5.2.0.tar.gz::https://github.com/ROCmSoftwarePlatform/hipCUB/archive/rocm-5.2.0.tar.gz
+ sha256sums = ac4dc2310f0eb657e1337c93d8cc4a5d8396f9544a7336eeceb455678a1f9139
pkgname = hipcub
diff --git a/PKGBUILD b/PKGBUILD
index a603ff82834e..f9e45c4659ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=hipcub
-pkgver=5.1.3
+pkgver=5.2.0
pkgrel=1
pkgdesc='Header-only library on top of rocPRIM or CUB'
arch=('x86_64')
-url='https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#hipcub'
+url='https://docs.amd.com/bundle/hipCUB-release-rocm-rel-5.2/page/introduction.html'
license=('custom')
depends=('rocprim')
makedepends=('cmake' 'rocm-cmake' 'git' 'hip')
_git='https://github.com/ROCmSoftwarePlatform/hipCUB'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('dc75640689b6a5e15dd3acea643266bdf114ea63efc60be8272f484cf8f04494')
+sha256sums=('ac4dc2310f0eb657e1337c93d8cc4a5d8396f9544a7336eeceb455678a1f9139')
_dirname="$(basename $_git)-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-5.1.x/docs/markdown/clang_options.md
+ # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.2/page/Appendix_A.html
CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \