summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2020-03-03 23:55:45 -0500
committerneeshy2020-03-07 14:29:30 -0500
commit5fcf403fdefddff7dc33a030b4683820a9993c2d (patch)
tree65ab225aa819c8ff74c0bf94bd8de2c27db9222c
parent39636e85c9b7cdbcb9205bfb60cc18d1a8188542 (diff)
downloadaur-5fcf403fdefddff7dc33a030b4683820a9993c2d.tar.gz
Cleanup
Consistent style across project Remove extraneous dependencies Update packages Update checksums and .SRCINFO Specify proper license Fix prefixes Prefer make to ninja Much more TODO: miopen, rocm-cmake{,-git}, rock-dkms{,-git}, Remove duplicates in makedepends and depends git submodules
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD40
2 files changed, 24 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 340ee29e4fb5..876c38450c12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,17 @@
pkgbase = hipcub
pkgdesc = Reusable software components for the rocm developers.
- pkgver = 3.0.0
+ pkgver = 3.1.0
pkgrel = 1
url = https://github.com/ROCmSoftwarePlatform/hipCUB
arch = x86_64
- license = NCSAOSL
- makedepends = git
+ license = custom:NCSAOSL
makedepends = cmake
- makedepends = gcc
- makedepends = ninja
- makedepends = hcc
makedepends = python2
makedepends = rocminfo
depends = hcc
depends = hip
- source = https://github.com/ROCmSoftwarePlatform/hipCUB/archive/3.0.0.tar.gz
- sha256sums = ee545d012e3af4c51f1a125bbe3b44f5eb4fd8a3c3a133edea19a8424e5b9d98
+ source = https://github.com/ROCmSoftwarePlatform/hipCUB/archive/3.1.0.tar.gz
+ sha256sums = 9fa41d9b25d5347ea6446ef32777dbe447257ccb494d82cb134529f4b45064a0
pkgname = hipcub
diff --git a/PKGBUILD b/PKGBUILD
index 08e7331ad3b3..49ed02fb16a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=hipcub
-pkgver=3.0.0
+pkgver=3.1.0
pkgrel=1
pkgdesc="Reusable software components for the rocm developers."
arch=('x86_64')
url="https://github.com/ROCmSoftwarePlatform/hipCUB"
-license=('NCSAOSL')
-depends=(hcc hip)
-makedepends=(git cmake gcc ninja hcc python2 rocminfo)
-srcver="3.0.0"
-source=("https://github.com/ROCmSoftwarePlatform/hipCUB/archive/$srcver.tar.gz")
-sha256sums=("ee545d012e3af4c51f1a125bbe3b44f5eb4fd8a3c3a133edea19a8424e5b9d98")
+license=('custom:NCSAOSL')
+depends=('hcc' 'hip')
+makedepends=('cmake' 'python2' 'rocminfo')
+source=("https://github.com/ROCmSoftwarePlatform/hipCUB/archive/$pkgver.tar.gz")
+sha256sums=('9fa41d9b25d5347ea6446ef32777dbe447257ccb494d82cb134529f4b45064a0')
build() {
mkdir -p "$srcdir/build"
@@ -21,26 +20,27 @@ build() {
[[ -e "$srcdir/python" ]] || ln -s /usr/bin/python2 "$srcdir/python"
# fix broken build with stack protection
- export CXXFLAGS=$(echo $CXXFLAGS | sed -e 's/-fstack-protector-strong//')
- export CFLAGS=$(echo $CFLAGS | sed -e 's/-fstack-protector-strong//')
- export CPPFLAGS=$(echo $CPPFLAGS | sed -e 's/-fstack-protector-strong//')
+ export CFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CFLAGS")"
+ export CXXFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CXXFLAGS")"
+ export CPPFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CPPFLAGS")"
# compile with HCC
- export CXX=/opt/rocm/hcc/bin/hcc
+ export CXX="/opt/rocm/hcc/bin/hcc"
# TODO: fix libhipcub.so, it contains references to $srcdir
cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="$pkgdir/opt/rocm/hipcub" \
- -G Ninja \
- "$srcdir/hipCUB-$srcver"
- ninja
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm/hipcub \
+ "$srcdir/hipCUB-$pkgver"
+ make
}
package() {
- ninja -C "$srcdir/build" install
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir" install
- mkdir -p $pkgdir/etc/ld.so.conf.d
- cat <<-EOF > $pkgdir/etc/ld.so.conf.d/hipcub.conf
- /opt/rocm/hipcub/lib/
- EOF
+ install -d "$pkgdir/etc/ld.so.conf.d"
+ cat << EOF > "$pkgdir/etc/ld.so.conf.d/hipcub.conf"
+/opt/rocm/hipcub/lib
+EOF
}