summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2022-03-18 04:02:55 -0500
committerGitHub2022-03-18 10:02:55 +0100
commit785ee96b724d00f3933f79fac29d164d375f109c (patch)
tree27c9e4ee6abadb502c2eaa3e39d95732a3dcf5b7
parentff18fe53887ee1f0a07acd233c34c763dda9324f (diff)
downloadaur-785ee96b724d00f3933f79fac29d164d375f109c.tar.gz
Use cmake -DAMDGPU_TARGETS=${AMDGPU_TARGETS} to specify GPU targets (#650)
hip-runtime-amd https://github.com/ROCm-Developer-Tools/hipamd/blob/develop/hip-config.cmake.in#L165 hipcub https://github.com/ROCmSoftwarePlatform/hipCUB/blob/develop/CMakeLists.txt#L62 hipfft https://github.com/ROCmSoftwarePlatform/hipfft/blob/develop/CMakeLists.txt#L108 rccl https://github.com/ROCmSoftwarePlatform/rccl/blob/develop/CMakeLists.txt#L45 rocalution https://github.com/ROCmSoftwarePlatform/rocalution/blob/develop/CMakeLists.txt#L84 rocblas https://github.com/ROCmSoftwarePlatform/rocblas/blob/develop/CMakeLists.txt#L91 rocfft https://github.com/ROCmSoftwarePlatform/rocfft/blob/develop/CMakeLists.txt#L142 rocrand https://github.com/ROCmSoftwarePlatform/rocrand/blob/develop/CMakeLists.txt#L79 rocsolver https://github.com/ROCmSoftwarePlatform/rocsolver/blob/develop/CMakeLists.txt#L128 rocsparse https://github.com/ROCmSoftwarePlatform/rocsparse/blob/develop/CMakeLists.txt#L158 rocthrust https://github.com/ROCmSoftwarePlatform/rocthrust/blob/develop/CMakeLists.txt#L68
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 119b625f6d00..7482efac57fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,8 @@ build() {
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
- -Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr
+ -Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
+ -DAMDGPU_TARGETS=${AMDGPU_TARGETS}
}
package() {