summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaetherm2020-04-07 07:31:34 +0200
committernaetherm2020-04-07 07:31:34 +0200
commitc4fa3b1c6abc1e179e1a607e38f38d27e8884efb (patch)
treec5412a053ddec080824eb6e850a215f5c8f44954
parent0984789cc8a2075e7524da66c5a61ed4538f02b3 (diff)
downloadaur-c4fa3b1c6abc1e179e1a607e38f38d27e8884efb.tar.gz
Updated hipcub to version 3.3.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a16b44b7e8bd..a56a27db1884 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hipcub
pkgdesc = Reusable software components for the rocm developers.
- pkgver = 3.1.0
+ pkgver = 3.3.0
pkgrel = 1
url = https://github.com/ROCmSoftwarePlatform/hipCUB
arch = x86_64
@@ -11,8 +11,8 @@ pkgbase = hipcub
makedepends = rocm-comgr
depends = hcc
depends = hip
- source = https://github.com/ROCmSoftwarePlatform/hipCUB/archive/3.1.0.tar.gz
- sha256sums = 9fa41d9b25d5347ea6446ef32777dbe447257ccb494d82cb134529f4b45064a0
+ source = https://github.com/ROCmSoftwarePlatform/hipCUB/archive/rocm-3.3.0.tar.gz
+ sha256sums = 0d97cada3b856e8c62affbb3664ac4fc2415a36ad3d9b9d7155b5f954e492392
pkgname = hipcub
diff --git a/PKGBUILD b/PKGBUILD
index 081280c22198..6bf85098fe2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=hipcub
-pkgver=3.1.0
+pkgver=3.3.0
pkgrel=1
pkgdesc="Reusable software components for the rocm developers."
arch=('x86_64')
@@ -8,8 +8,8 @@ url="https://github.com/ROCmSoftwarePlatform/hipCUB"
license=('custom:NCSAOSL')
depends=('hcc' 'hip')
makedepends=('cmake' 'python2' 'rocminfo' 'rocm-comgr')
-source=("https://github.com/ROCmSoftwarePlatform/hipCUB/archive/$pkgver.tar.gz")
-sha256sums=('9fa41d9b25d5347ea6446ef32777dbe447257ccb494d82cb134529f4b45064a0')
+source=("https://github.com/ROCmSoftwarePlatform/hipCUB/archive/rocm-$pkgver.tar.gz")
+sha256sums=('0d97cada3b856e8c62affbb3664ac4fc2415a36ad3d9b9d7155b5f954e492392')
build() {
mkdir -p "$srcdir/build"
@@ -31,7 +31,7 @@ build() {
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/opt/rocm/hipcub \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
- "$srcdir/hipCUB-$pkgver"
+ "$srcdir/hipCUB-rocm-$pkgver"
make
}