summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2020-06-05 19:47:52 +0200
committerGitHub2020-06-05 13:47:52 -0400
commitf7d5b54b14f74afd8b6ddf1660c892f715a19f85 (patch)
tree5c8ab4888d44829ee08f9cd25e353058ca477edb
parent9fb7fd5479a701369802ccd1dccd063572daa6ea (diff)
downloadaur-f7d5b54b14f74afd8b6ddf1660c892f715a19f85.tar.gz
[hipcub] Update to 3.5.0 (#193)
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43021befcceb..67fcd0844aa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = hipcub
pkgdesc = Header-only library on top of rocPRIM or CUB
- pkgver = 3.3.0
- pkgrel = 2
- url = https://github.com/ROCmSoftwarePlatform/hipCUB
+ pkgver = 3.5.0
+ pkgrel = 1
+ url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#hipcub
arch = x86_64
license = custom
makedepends = cmake
makedepends = git
- makedepends = hcc
+ makedepends = hip-rocclr
depends = rocprim
- optdepends = cuda: CUB backend
- source = https://github.com/ROCmSoftwarePlatform/hipCUB/archive/rocm-3.3.0.tar.gz
- sha256sums = 0d97cada3b856e8c62affbb3664ac4fc2415a36ad3d9b9d7155b5f954e492392
+ source = hipcub-3.5.0.tar.gz::https://github.com/ROCmSoftwarePlatform/hipCUB/archive/rocm-3.5.0.tar.gz
+ sha256sums = 1eb2cb5f6e90ed1b7a9ac6dd86f09ec2ea27bceb5a92eeffa9c2123950c53b9d
pkgname = hipcub
diff --git a/PKGBUILD b/PKGBUILD
index 661056a8f600..4408f6c6a25d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=hipcub
-pkgver=3.3.0
-pkgrel=2
+pkgver=3.5.0
+pkgrel=1
pkgdesc='Header-only library on top of rocPRIM or CUB'
arch=('x86_64')
url='https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#hipcub'
license=('custom')
depends=('rocprim')
-optdepends=('cuda: CUB backend')
-makedepends=('cmake' 'git' 'hcc')
-source=("$url/archive/rocm-$pkgver.tar.gz")
-sha256sums=('0d97cada3b856e8c62affbb3664ac4fc2415a36ad3d9b9d7155b5f954e492392')
+makedepends=('cmake' 'git' 'hip-rocclr')
+_git='https://github.com/ROCmSoftwarePlatform/hipCUB'
+source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
+sha256sums=('1eb2cb5f6e90ed1b7a9ac6dd86f09ec2ea27bceb5a92eeffa9c2123950c53b9d')
build() {
mkdir -p build
cd build
- CXX=/opt/rocm/hcc/bin/hcc \
+ CXX=/opt/rocm/hip/bin/hipcc \
cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm/hipcub \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
"$srcdir/hipCUB-rocm-$pkgver"