summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilip Matzner2019-04-15 21:55:15 +0200
committerFilip Matzner2019-04-15 21:56:44 +0200
commit46aa8786170acbde03f6de9eae29808c2bf40197 (patch)
treeb2ddf6de1d7363be9d3155c10fc01f1197b75601
downloadaur-46aa8786170acbde03f6de9eae29808c2bf40197.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e83f7f29306
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hipipe
+ pkgdesc = Super fast C++17 data transformation pipeline (with Python interface).
+ pkgver = 0.6.0
+ pkgrel = 0
+ url = https://github.com/iterait/hipipe
+ arch = any
+ license = custom
+ makedepends = cmake
+ makedepends = git
+ depends = boost
+ depends = opencv
+ depends = python
+ depends = python-numpy
+ depends = range-v3
+ source = https://github.com/iterait/hipipe/archive/v0.6.0.tar.gz
+ sha512sums = 97758f39e0973d6c8c402d6980c253059652e0e2bd4b509852f8f7d2ca7ec8cbf80c07b0ae9ba759ffbba160bbe206fd05a494b8354bda1718132dcac6aecf66
+
+pkgname = hipipe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06473b289749
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Filip Matzner <filip.matzner@iterait.com>
+
+pkgname=hipipe
+pkgver=0.6.0
+pkgrel=0
+pkgdesc='Super fast C++17 data transformation pipeline (with Python interface).'
+arch=('any')
+url='https://github.com/iterait/hipipe'
+license=('custom')
+depends=('boost' 'opencv' 'python' 'python-numpy' 'range-v3')
+makedepends=('cmake' 'git')
+source=("https://github.com/iterait/hipipe/archive/v${pkgver}.tar.gz")
+sha512sums=('97758f39e0973d6c8c402d6980c253059652e0e2bd4b509852f8f7d2ca7ec8cbf80c07b0ae9ba759ffbba160bbe206fd05a494b8354bda1718132dcac6aecf66')
+
+prepare() {
+ cd "${srcdir}/hipipe-${pkgver}"
+ rm -rf build && mkdir build
+}
+
+build() {
+ cd "${srcdir}/hipipe-${pkgver}"
+
+ cd build
+ cmake .. \
+ -DHIPIPE_BUILTIN_RANGEV3=OFF \
+ -DHIPIPE_BUILD_TEST=OFF
+ make -j8
+}
+
+package() {
+ cd "${srcdir}/hipipe-${pkgver}"
+ install -Dm644 "LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ cd build
+ make DESTDIR="${pkgdir}/" install
+}