summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro Martinez-Julia2015-07-21 11:40:23 +0200
committerPedro Martinez-Julia2015-07-21 11:40:23 +0200
commit080a6f6b7d22500218443814f760329e0eee34c2 (patch)
treea5604a01d1031adb45f0ae1eb3fa70fd783b1696
downloadaur-hipl.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e1a6bc04466
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hipl
+ pkgdesc = Implementation of the Host Identity Protocol (HIP) for Linux.
+ pkgver = 20130906
+ pkgrel = 1
+ url = http://infrahip.hiit.fi
+ arch = i686
+ arch = x86_64
+ license = MIT
+ license = GPL
+ makedepends = automake
+ makedepends = libtool
+ depends = libnetfilter_queue
+ depends = python2
+ depends = perl-net-dns
+ source = http://hipl.hiit.fi/hipl/hipl.tar.gz
+ sha256sums = e9779f00d1466355777b48050123487d01d3b19475a9a030535ee097ed8988fb
+
+pkgname = hipl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d89e815ced6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer : Pedro Martinez-Julia <pedromj@um.es>
+
+pkgname=hipl
+pkgver=20130906
+pkgrel=1
+pkgdesc="Implementation of the Host Identity Protocol (HIP) for Linux."
+arch=('i686' 'x86_64')
+url="http://infrahip.hiit.fi"
+license=('MIT' 'GPL')
+makedepends=('automake' 'libtool')
+depends=('libnetfilter_queue' 'python2' 'perl-net-dns')
+source=(http://hipl.hiit.fi/hipl/${pkgname}.tar.gz)
+sha256sums=('e9779f00d1466355777b48050123487d01d3b19475a9a030535ee097ed8988fb')
+
+build() {
+ cd "$srcdir"/hipl-1.0.8
+ for file in tools/hipdnskeyparse/hipdnskeyparse.in tools/hipdnsproxy/hipdnsproxy.in tools/hipdnsproxy/DNS/Serialization.py tools/hipdnskeyparse/myasn.py tools/hipdnsproxy/dnsproxy.py tools/hipdnsproxy/hosts.py tools/hipdnsproxy/resolvconf.py tools/hipdnsproxy/resolvconf_test.py tools/hipdnsproxy/util.py; do
+ sed -i "s/env python$/env python2/g" $file
+ done
+ PYTHON=python2 ./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd ${srcdir}/hipl-1.0.8
+ make DESTDIR="${pkgdir}" install
+ install -m644 -D COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+}