summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Bernard2020-04-27 18:15:47 +0200
committerSamuel Bernard2020-04-28 21:46:11 +0200
commit84ef9ae9f31b6e7f53f39b370aaa72cbd084bee0 (patch)
tree63bafca84821acbb5a00398d55661707e5b19091
parentd30d2016189f4ea9a07656bb0ec3050bdc1fcda2 (diff)
downloadaur-84ef9ae9f31b6e7f53f39b370aaa72cbd084bee0.tar.gz
hipsparse: update to 3.3.0
- compile with hipcc and remove patch - simplify CMAKE cmdline - use python as makedep instead of python2
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
-rw-r--r--hipsparse_hsa.patch12
3 files changed, 20 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3270b269c179..dd9dcbd1113f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = hipsparse
pkgdesc = ROCm SPARSE marshalling library.
- pkgver = 3.1.0
- pkgrel = 3
+ pkgver = 3.3.0
+ pkgrel = 1
url = https://github.com/ROCmSoftwarePlatform/hipSPARSE
arch = x86_64
license = custom:NCSAOSL
makedepends = cmake
- makedepends = hcc>=3.1.0
- makedepends = hip>=3.1.0
- makedepends = python2
- makedepends = rocprim>=3.1.0
- makedepends = rocsparse>=3.1.0
- makedepends = comgr>=3.1.0
+ makedepends = hcc>=3.3.0
+ makedepends = hip>=3.3.0
+ makedepends = python
+ makedepends = rocprim>=3.3.0
+ makedepends = rocsparse>=3.3.0
+ makedepends = comgr>=3.3.0
makedepends = rocminfo
depends = hcc
depends = hip
- source = https://github.com/ROCmSoftwarePlatform/hipSPARSE/archive/rocm-3.1.tar.gz
- source = hipsparse_hsa.patch
- sha256sums = df210c1dd18a23b8013558ea82058601a75d8572ad54d13d59beb6746759ced6
- sha256sums = d3a926958b84c660f273d6b3a644e8a775e9ed779a7d81baa8f4c4981cee076b
+ source = https://github.com/ROCmSoftwarePlatform/hipSPARSE/archive/rocm-3.3.0.tar.gz
+ sha256sums = c69336071f56c857e969f0fdfbc351f75cc44ed2e3b854b4688675a9cafe4e22
pkgname = hipsparse
diff --git a/PKGBUILD b/PKGBUILD
index d36bff823f95..1693cee95ea6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,15 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=hipsparse
-_pkgver=3.1
-pkgver="$_pkgver.0"
-pkgrel=3
+pkgver=3.3.0
+pkgrel=1
pkgdesc="ROCm SPARSE marshalling library."
arch=('x86_64')
url="https://github.com/ROCmSoftwarePlatform/hipSPARSE"
license=('custom:NCSAOSL')
depends=('hcc' 'hip')
-makedepends=('cmake' "hcc>=$pkgver" "hip>=$pkgver" 'python2' "rocprim>=$pkgver" "rocsparse>=$pkgver" "comgr>=$pkgver" 'rocminfo')
-source=("https://github.com/ROCmSoftwarePlatform/hipSPARSE/archive/rocm-$_pkgver.tar.gz"
- "hipsparse_hsa.patch")
-sha256sums=('df210c1dd18a23b8013558ea82058601a75d8572ad54d13d59beb6746759ced6'
- 'd3a926958b84c660f273d6b3a644e8a775e9ed779a7d81baa8f4c4981cee076b')
-
-prepare() {
- cd "$srcdir/hipSPARSE-rocm-$_pkgver"
- patch -Np1 -i "$srcdir/hipsparse_hsa.patch"
-}
+makedepends=('cmake' "hcc>=$pkgver" "hip>=$pkgver" 'python' "rocprim>=$pkgver" "rocsparse>=$pkgver" "comgr>=$pkgver" 'rocminfo')
+source=("https://github.com/ROCmSoftwarePlatform/hipSPARSE/archive/rocm-$pkgver.tar.gz")
+sha256sums=('c69336071f56c857e969f0fdfbc351f75cc44ed2e3b854b4688675a9cafe4e22')
build() {
mkdir -p "$srcdir/build"
@@ -28,20 +20,17 @@ build() {
export CXXFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CXXFLAGS")"
export CPPFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CPPFLAGS")"
- # compile with HCC
- export CXX="/opt/rocm/hcc/bin/hcc"
+ # compile with hipcc
+ export CXX="/opt/rocm/hip/bin/hipcc"
# TODO: fix librocsparse.so, it contains references to $srcdir
cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=opt/rocm/hipsparse \
- -Dhcc_DIR=/opt/rocm/hcc/lib/cmake/hcc \
- -Dhip_DIR=/opt/rocm/hip/lib/cmake/hip \
- -Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
- -Drocsparse_DIR=/opt/rocm/rocsparse/lib/cmake/rocsparse \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm/hipsparse \
-DBUILD_CLIENTS_SAMPLES=OFF \
-DBUILD_CLIENTS_TESTS=OFF \
- -DHSA_HEADER=/opt/rocm/hsa/include \
+ -Drocsparse_DIR=/opt/rocm/rocsparse/lib/cmake/rocsparse \
"$srcdir/hipSPARSE-rocm-$_pkgver"
+
make
}
diff --git a/hipsparse_hsa.patch b/hipsparse_hsa.patch
deleted file mode 100644
index bc3185cba089..000000000000
--- a/hipsparse_hsa.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --unified --recursive --text hipSPARSE-rocm-3.0/library/CMakeLists.txt hipSPARSE-rocm-3.0/library/CMakeLists.txt
---- hipSPARSE-rocm-3.0/library/CMakeLists.txt 2019-10-08 20:12:42.000000000 +0200
-+++ hipSPARSE-rocm-3.0/library/CMakeLists.txt 2020-02-01 14:36:13.142332177 +0100
-@@ -142,6 +142,8 @@
-
- set(HIPSPARSE_CONFIG_DIR "\${CPACK_PACKAGING_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}" CACHE PATH "Path placed into ldconfig file")
-
-+include_directories("/opt/rocm/hsa/include")
-+
- rocm_create_package(
- NAME ${package_name}
- DESCRIPTION "Radeon Open Compute SPARSE library"