summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAksel Alpay2018-09-29 02:57:11 +0200
committerAksel Alpay2018-09-29 02:57:11 +0200
commit376df91a5819bc94447f8c1818accd307c743b01 (patch)
tree1a886e3578d4fa0c301d6d244d9dc3e5aadaaf25
downloadaur-376df91a5819bc94447f8c1818accd307c743b01.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b332645eee8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hipsycl-rocm-git
+ pkgdesc = SYCL implementation over CUDA/HIP for AMD devices.
+ pkgver = 0.6.8
+ pkgrel = 1
+ url = https://github.com/illuhad/hipSYCL
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ provides = hipSYCL
+ provides = SYCL
+ source = hipSYCL::git+https://github.com/illuhad/hipSYCL.git
+ md5sums = SKIP
+
+pkgname = hipsycl-rocm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3174d20092a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Aksel Alpay <alpay at stud dot uni-heidelberg dot de>
+pkgname=hipsycl-rocm-git
+pkgver=0.6.8
+pkgrel=1
+pkgdesc="SYCL implementation over CUDA/HIP for AMD devices."
+arch=("x86_64")
+url="https://github.com/illuhad/hipSYCL"
+makedepends=("cmake")
+provides=("hipSYCL" "SYCL")
+license=("BSD")
+
+source=('hipSYCL::git+https://github.com/illuhad/hipSYCL.git')
+
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/hipSYCL"
+ git log -1 --format=%cd.%h --date=short|tr -d -
+}
+
+prepare() {
+ cd "${srcdir}/hipSYCL/contrib/HIP"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ export HIPSYCL_PLATFORM=rocm
+ mkdir -p ${srcdir}/hipSYCL/build
+ cd "${srcdir}/hipSYCL/build"
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/hipSYCL/ROCm ..
+}
+
+package() {
+ export HIPSYCL_PLATFORM=rocm
+ cd "${srcdir}/hipSYCL/build"
+ VERBOSE=1 DESTDIR=${pkgdir} make install
+}