summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-03-24 17:17:01 -0400
committeracxz2020-03-24 17:17:01 -0400
commitc8e025ab7fdfc5fb37f0a54695b0481200dfa9f9 (patch)
tree0df6b8d32f984384ff28d9d1784f9876fc91feee
parent9cfc68b072b078e4d5ae3577712bffefcaec6100 (diff)
downloadaur-c8e025ab7fdfc5fb37f0a54695b0481200dfa9f9.tar.gz
upd deps
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
2 files changed, 37 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 216e78055f8c..2feaa04a7a9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hipsycl-rocm-git
- pkgdesc = SYCL implementation over CUDA/HIP for AMD devices.
- pkgver = 0.7.9
+ pkgdesc = Implementation of SYCL 1.2.1 over AMD HIP/NVIDIA CUDA
+ pkgver = r500.5f30bc1
pkgrel = 1
url = https://github.com/illuhad/hipSYCL
arch = x86_64
@@ -8,12 +8,17 @@ pkgbase = hipsycl-rocm-git
makedepends = cmake
depends = llvm
depends = clang
+ depends = python
depends = boost
+ depends = hipcpu
depends = openmp
- provides = hipSYCL
- provides = SYCL
- source = hipSYCL::git+https://github.com/illuhad/hipSYCL.git
- md5sums = SKIP
+ depends = hip-hcc
+ depends = rocm
+ provides = hipsycl-rocm
+ provides = hipsycl
+ provides = sycl
+ source = hipsycl::git+https://github.com/illuhad/hipSYCL.git
+ sha256sums = SKIP
pkgname = hipsycl-rocm-git
diff --git a/PKGBUILD b/PKGBUILD
index 297f00eab172..8922ccff8a52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,45 @@
# Maintainer: Aksel Alpay <aksel.alpay at uni-heidelberg dot de>
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+
pkgname=hipsycl-rocm-git
-pkgver=0.7.9
+pkgver=r500.5f30bc1
pkgrel=1
-pkgdesc="SYCL implementation over CUDA/HIP for AMD devices."
+pkgdesc="Implementation of SYCL 1.2.1 over AMD HIP/NVIDIA CUDA"
arch=("x86_64")
url="https://github.com/illuhad/hipSYCL"
-makedepends=("cmake")
-provides=("hipSYCL" "SYCL")
license=("BSD")
-depends=("llvm" "clang" "boost" "openmp")
-
-source=('hipSYCL::git+https://github.com/illuhad/hipSYCL.git')
-
-md5sums=("SKIP")
+provides=(hipsycl-rocm hipsycl sycl)
+makedepends=(cmake)
+depends=(llvm clang python boost hipcpu openmp hip-hcc rocm)
+_pkgname=hipsycl
+source=("${_pkgname}::git+https://github.com/illuhad/hipSYCL.git")
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/hipSYCL"
- git log -1 --format=%cd.%h --date=short|tr -d -
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "${srcdir}/hipSYCL/contrib/HIP"
- git submodule init
- git submodule update
+ # Delete the install lines for contrib hip and hipcpu
+ sed -i '/contrib/d' ${srcdir}/${_pkgname}/CMakeLists.txt
}
build() {
- mkdir -p ${srcdir}/hipSYCL/build
- cd "${srcdir}/hipSYCL/build"
- cmake -DCMAKE_BUILD_TYPE=Release \
+ mkdir -p ${srcdir}/${_pkgname}/build
+ cd ${srcdir}/${_pkgname}/build
+
+ cmake .. -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/opt/hipSYCL/ROCm \
- -DWITH_CPU_BACKEND=ON -DWITH_ROCM_BACKEND=ON ..
+ -DWITH_CUDA_BACKEND=OFF \
+ -DWITH_ROCM_BACKEND=ON \
+ -DWITH_CPU_BACKEND=ON
+
+ make
+
}
package() {
- cd "${srcdir}/hipSYCL/build"
- VERBOSE=1 DESTDIR=${pkgdir} make install
+ cd "${srcdir}/${_pkgname}/build"
+ make DESTDIR=${pkgdir} install
}