summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Zhao2016-07-02 00:23:26 +0200
committerMax Zhao2016-07-02 00:23:26 +0200
commit7888dbf553e98c4dc8aa38b4e0f31ada1823cdd0 (patch)
tree98dad1e78d42e6560d1cddf66c3dd035b1ca5030
parent002f6a2960f882eb67735dfb43af781a82e29593 (diff)
downloadaur-7888dbf553e98c4dc8aa38b4e0f31ada1823cdd0.tar.gz
changes
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--ffmpeg.patch52
3 files changed, 13 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ac910d88c9d..d3d852a35673 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jun 21 22:43:06 UTC 2016
+# Fri Jul 1 22:23:05 UTC 2016
pkgbase = hiptext
pkgdesc = hiptext is command line tool for rendering images and videos inside terminals.
- pkgver = r102.f89b44f
+ pkgver = 0.1
pkgrel = 1
url = https://github.com/jart/hiptext
arch = any
@@ -15,11 +15,11 @@ pkgbase = hiptext
makedepends = ffmpeg
makedepends = gflags
makedepends = google-glog
- source = hiptext::git://github.com/jart/hiptext.git
+ source = https://github.com/jart/hiptext/archive/0.1.tar.gz
source = ffmpeg.patch
source = hiptext.sh
- md5sums = SKIP
- md5sums = 86ade16ec71e7a49cb6136973419547f
+ md5sums = a028fb0b95a8745e81258614c92064e1
+ md5sums = 0a6b5cb5275f71f29027f1f5cc1c4b50
md5sums = 29c7c80e4c783406948a51034d15076c
pkgname = hiptext
diff --git a/PKGBUILD b/PKGBUILD
index 11b9e633f826..18ee914f03b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Max Zhao <alcasa.mz@gmail.com>
pkgname=hiptext
-pkgver=r101.1cc777a
+pkgver=0.1
pkgrel=1
pkgdesc="hiptext is command line tool for rendering images and videos inside terminals."
arch=('any')
@@ -27,33 +27,29 @@ backup=()
options=()
install=
changelog=
-source=("hiptext::git://github.com/jart/hiptext.git"
+source=("https://github.com/jart/hiptext/archive/0.1.tar.gz"
"ffmpeg.patch"
"hiptext.sh")
noextract=()
-md5sums=('SKIP'
- '86ade16ec71e7a49cb6136973419547f'
+md5sums=('a028fb0b95a8745e81258614c92064e1'
+ '0a6b5cb5275f71f29027f1f5cc1c4b50'
'29c7c80e4c783406948a51034d15076c')
-pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
prepare() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
patch -p1 -i "../ffmpeg.patch"
}
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
mkdir -p "$pkgdir/usr/share/$pkgname/bin"
mkdir -p "$pkgdir/usr/bin"
make PREFIX="$pkgdir/usr/share/$pkgname" install
cp "$srcdir/hiptext.sh" "$pkgdir/usr/bin/hiptext"
- cp "$srcdir/$pkgname/DejaVuSansMono.ttf" "$pkgdir/usr/share/$pkgname/dejavu.ttf"
+ cp "$srcdir/$pkgname-$pkgver/DejaVuSansMono.ttf" "$pkgdir/usr/share/$pkgname/dejavu.ttf"
}
diff --git a/ffmpeg.patch b/ffmpeg.patch
index 1440a22ba4ef..65b813a27415 100644
--- a/ffmpeg.patch
+++ b/ffmpeg.patch
@@ -1,16 +1,3 @@
-diff --git a/graphic.cc b/graphic.cc
-index 419d7df..ec5acf1 100644
---- a/graphic.cc
-+++ b/graphic.cc
-@@ -55,7 +55,7 @@ Graphic& Graphic::Equalize() {
- return std::min(255, std::max(0, static_cast<int>(v * kBins)));
- };
-
-- // Count the occurrence of each color into bins.
-+ // Count the occurence of each color into bins.
- for (int y = 0; y < height_; ++y) {
- for (int x = 0; x < width_; ++x) {
- const Pixel& pixel = Get(x, y);
diff --git a/hiptext.cc b/hiptext.cc
index a23fa02..f21c483 100644
--- a/hiptext.cc
@@ -30,19 +17,6 @@ index a23fa02..f21c483 100644
artiste.PrintMovie(Movie(path));
} else {
fprintf(stderr, "Unknown Filetype: %s\n", extension.data());
-diff --git a/macterm.cc b/macterm.cc
-index 1042a9a..20ba55f 100644
---- a/macterm.cc
-+++ b/macterm.cc
-@@ -99,7 +99,7 @@ MactermColor::MactermColor(const Pixel& top, const Pixel& bot) {
- // Terminal.app on Mac OS X is interesting. First of all, it doesn't follow the
- // xterm-256color standard, but that's probably for the best since xterm's
- // palette was obviously chosen by engineers rather than designers. The problem
--// is I'm not quite sure what Terminal.app is doing. It slightly adjusts the
-+// is I'm not quite sure what Terminal.app is doing. It slightly ajusts the
- // color when displaying foregrounds and backgrounds but I'm not sure what
- // formula they're using to do it. They also seem to slightly alter colors
- // depending on the terminal theme. The following colors are what I scraped
diff --git a/movie.cc b/movie.cc
index 9ad9368..4fb6b73 100644
--- a/movie.cc
@@ -74,29 +48,3 @@ index 9ad9368..4fb6b73 100644
CHECK_GE(prep, 0) << "Failed to prepare RGB buffer.";
LOG(INFO) << "RGB dimensions: " << width_ << "x" << height_;
}
-diff --git a/pixel.cc b/pixel.cc
-index eb52f61..2a6ecdf 100644
---- a/pixel.cc
-+++ b/pixel.cc
-@@ -166,7 +166,7 @@ Pixel& Pixel::Mix(const Pixel& other) {
-
- // http://www.springerreference.com/docs/html/chapterdbid/212829.html
- static double A(double c) {
-- // This is K/S part of the equations on that website.
-+ // This is K/S part of the the equations on that website.
- // a = (1 - c)^2 / (2c)
- return std::pow(1.0 - c, 2.0) / (2.0 * max(c, 1e-6));
- }
-diff --git a/xterm256.cc b/xterm256.cc
-index 0db765e..1622255 100644
---- a/xterm256.cc
-+++ b/xterm256.cc
-@@ -6,7 +6,7 @@
- #include <glog/logging.h>
- #include "pixel.h"
-
--DEFINE_bool(fast, false, "Use O(1) xterm256 approximate color quantizer.");
-+DEFINE_bool(fast, false, "Use O(1) xterm256 aproximate color quantizer.");
-
- static const uint8_t g_cube_steps[] = {0, 95, 135, 175, 215, 255};
-