summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Tharp2017-10-11 10:39:36 -0500
committerAlex Tharp2017-10-11 10:39:36 -0500
commitffd78d672f21d346f704562f2d63e9d00705afd3 (patch)
treebfb9c36d803a9a2cbc4506926dbe9d44db8d52e9
parent779642d4e6f5f12b0d529e006d6c2402b201dab9 (diff)
downloadaur-ffd78d672f21d346f704562f2d63e9d00705afd3.tar.gz
refactor: remove unnecessary dependencies, add supported MimeType to desktop entry
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
-rw-r--r--hiri.desktop1
3 files changed, 5 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5696a8c75b9a..9c05a47e5833 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,11 @@
pkgbase = hiri
pkgdesc = A cross-platform, Exchange-ready email client aiming to replace Outlook
pkgver = 1.2.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.hiri.com/
install = hiri.install
arch = x86_64
license = custom
- depends = python-pyqt5
- depends = qt5-webkit
- depends = python-pyenchant
provides = hiri
conflicts = hiri
source = https://feedback.hiri.com/dist/downloads/Hiri-x86_64-1.2.3.0.tar.gz
@@ -17,7 +14,7 @@ pkgbase = hiri
source = hiri.sh
sha512sums = 3b080f78f74ffccaebfc6719b9f23ef542f4bc4ac0dba48c01f44697323600cb284c0774356f07cd9d61cd28127422eed5abc111e1e9f5422846aff3115cff26
sha512sums = ae8274026cb1b68f9b3f4cb66348952e19e31d477602a3d6d529121010260727824d0a060303e10fa8c5661f0b336ceabb0b472ad1cb74835ff5d6f3d3d53636
- sha512sums = cc50dc92bd28bb3178a857b436d0958077b1f6ede643a65cd5d6b900dc05d6b73f04ea1fe76af6298841bffb08f8d4fd94796b9511feeeaf2f3de8a6e163304c
+ sha512sums = 4bf85f50fe25aa4980f97f5fdc5111d4e77af7268f70407f897252fc9cc4901f2d7d148172e242f33856b2839378996ca72c0314a9f8b3673e2449067b19baad
sha512sums = cafbf1f327618cb1d8914babf9cc9c2013b5db27df2a463329f9d366952c5ee592e946e727f991c8f7f558bdf7e625b91e0e029fa193650c197c6c9c6a57676d
pkgname = hiri
diff --git a/PKGBUILD b/PKGBUILD
index c0e2d04b5260..d120dfc46e11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,13 @@
# Original Maintainer: Muratcan Sisek <mail@muratcansimsek.com.tr>
pkgname=hiri
pkgver=1.2.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform, Exchange-ready email client aiming to replace Outlook"
arch=('x86_64')
url="https://www.hiri.com/"
license=('custom')
provides=('hiri')
conflicts=('hiri')
-depends=('python-pyqt5'
- 'qt5-webkit'
- 'python-pyenchant')
install=$pkgname.install
source=('https://feedback.hiri.com/dist/downloads/Hiri-'$arch'-'$pkgver'.tar.gz'
'https://feedback.hiri.com/dist/downloads/license.txt'
@@ -19,7 +16,7 @@ source=('https://feedback.hiri.com/dist/downloads/Hiri-'$arch'-'$pkgver'.tar.gz'
'hiri.sh')
sha512sums=('3b080f78f74ffccaebfc6719b9f23ef542f4bc4ac0dba48c01f44697323600cb284c0774356f07cd9d61cd28127422eed5abc111e1e9f5422846aff3115cff26'
'ae8274026cb1b68f9b3f4cb66348952e19e31d477602a3d6d529121010260727824d0a060303e10fa8c5661f0b336ceabb0b472ad1cb74835ff5d6f3d3d53636'
- 'cc50dc92bd28bb3178a857b436d0958077b1f6ede643a65cd5d6b900dc05d6b73f04ea1fe76af6298841bffb08f8d4fd94796b9511feeeaf2f3de8a6e163304c'
+ '4bf85f50fe25aa4980f97f5fdc5111d4e77af7268f70407f897252fc9cc4901f2d7d148172e242f33856b2839378996ca72c0314a9f8b3673e2449067b19baad'
'cafbf1f327618cb1d8914babf9cc9c2013b5db27df2a463329f9d366952c5ee592e946e727f991c8f7f558bdf7e625b91e0e029fa193650c197c6c9c6a57676d')
build () {
diff --git a/hiri.desktop b/hiri.desktop
index bb92075427e7..ffd33e332de8 100644
--- a/hiri.desktop
+++ b/hiri.desktop
@@ -7,3 +7,4 @@ Terminal=false
StartupNotify=true
Exec=/opt/hiri/hiri.sh %u
Icon=/opt/hiri/hiri.png
+MimeType=x-scheme-handler/mailto;