summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A.2024-11-02 17:00:35 +0100
committerPhilipp A.2024-11-02 17:00:35 +0100
commitd504cab7b27d21c7bfa5a0dfdfd0f5f30ddab42e (patch)
tree7eee136d16120c72087acb6011aaa3e4c46f1a1c
parent9856d9a52b10f78daafef589f8686b1ac33090aa (diff)
downloadaur-d504cab7b27d21c7bfa5a0dfdfd0f5f30ddab42e.tar.gz
upgpkg: hisat2 2.2.1-2
Update hisat2 website
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d93076051eb..b7188e594aba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = hisat2
pkgdesc = A fast and sensitive alignment program for mapping next-generation sequencing reads against genomes
pkgver = 2.2.1
- pkgrel = 1
- url = https://ccb.jhu.edu/software/hisat2
+ pkgrel = 2
+ url = https://daehwankimlab.github.io/hisat2
arch = x86_64
- license = GPL3
- optdepends = python: To use the wrapper scripts instead of -l and -s variants
- source = hisat2-2.2.1-source.zip::https://cloud.biohpc.swmed.edu/index.php/s/fE9QCsX3NH4QwBi/download
- sha256sums = 48e933330d4d8470d2b3dfe7ec3918f2e98a75f7381891e23b7df1fb4f135eb1
+ license = GPL-3.0-only
+ depends = perl
+ optdepends = perl: To use the `hisat2` wrapper script
+ optdepends = python: To use the `hisat2-{build,build-new,inspect}` scripts
+ source = hisat2-2.2.1.tar.gz::https://github.com/DaehwanKimLab/hisat2/archive/refs/tags/v2.2.1.tar.gz
+ sha256sums = f3f4f867d0a6b1f880d64efc19deaa5788c62050e0a4d614ce98b3492f702599
pkgname = hisat2
-
diff --git a/PKGBUILD b/PKGBUILD
index 41b95c281af7..e13f49cdc545 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,17 @@
pkgname=hisat2
pkgver=2.2.1
-pkgrel=1
+pkgrel=2
pkgdesc='A fast and sensitive alignment program for mapping next-generation sequencing reads against genomes'
-url="https://ccb.jhu.edu/software/$pkgname"
-license=(GPL3)
+url="https://daehwankimlab.github.io/$pkgname"
+license=(GPL-3.0-only)
arch=(x86_64)
-optdepends=('python: To use the wrapper scripts instead of -l and -s variants')
-source=("$pkgname-$pkgver-source.zip::https://cloud.biohpc.swmed.edu/index.php/s/fE9QCsX3NH4QwBi/download")
-sha256sums=('48e933330d4d8470d2b3dfe7ec3918f2e98a75f7381891e23b7df1fb4f135eb1')
+depends=(perl)
+optdepends=(
+ 'perl: To use the `hisat2` wrapper script'
+ 'python: To use the `hisat2-{build,build-new,inspect}` scripts'
+)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/DaehwanKimLab/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('f3f4f867d0a6b1f880d64efc19deaa5788c62050e0a4d614ce98b3492f702599')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -19,4 +23,5 @@ package() {
for bin in hisat2 hisat2-*; do
install -Dm755 $bin "$pkgdir/usr/bin/$bin"
done
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}