summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2018-02-01 11:14:33 +0100
committerPhilipp A2018-02-01 11:14:33 +0100
commitf0be65782d10b087a8e60ba980d669846dff5ae3 (patch)
treef535a3d2c939f80c20e6a8d046644fcda3690288
downloadaur-f0be65782d10b087a8e60ba980d669846dff5ae3.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8991d19b8c75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hisat2
+ pkgdesc = A fast and sensitive alignment program for mapping next-generation sequencing reads against genomes
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://ccb.jhu.edu/software/hisat2
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ source = ftp://ftp.ccb.jhu.edu/pub/infphilo/hisat2/downloads/hisat2-2.1.0-source.zip
+ sha256sums = 89a276eed1fc07414b1601947bc9466bdeb50e8f148ad42074186fe39a1ee781
+
+pkgname = hisat2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1d41ea0663a1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.pkg.tar.xz
+/*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef3209d37db9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=hisat2
+pkgver=2.1.0
+pkgrel=1
+pkgdesc='A fast and sensitive alignment program for mapping next-generation sequencing reads against genomes'
+url="https://ccb.jhu.edu/software/$pkgname"
+license=(GPLv3)
+arch=(i686 x86_64)
+source=("ftp://ftp.ccb.jhu.edu/pub/infphilo/$pkgname/downloads/$pkgname-$pkgver-source.zip")
+sha256sums=('89a276eed1fc07414b1601947bc9466bdeb50e8f148ad42074186fe39a1ee781')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ for bin in hisat2 hisat2-*; do
+ install -Dm755 $bin "$pkgdir/usr/bin/$bin"
+ done
+}