summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorravi0li2021-09-08 12:07:24 +0200
committerravi0li2021-09-08 12:07:24 +0200
commit536fbef7c39b9aba29af68740c81a6e2d848f5a3 (patch)
tree4936b05583cc7c5d4c249090443b66f2e6ecf4b2
downloadaur-hledger-flow-bin.tar.gz
v0.15.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b79212cee656
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hledger-flow-bin
+ pkgdesc = An hledger/ledger-cli workflow focusing on automated statement import and classification
+ pkgver = 0.15.0
+ pkgrel = 1
+ url = https://github.com/apauley/hledger-flow
+ arch = x86_64
+ license = GPL
+ source = https://github.com/apauley/hledger-flow/releases/download/v0.15.0/hledger-flow_Linux_x86_64_v0.15.0_2b025fe.tar.gz
+ source = https://raw.githubusercontent.com/apauley/hledger-flow/master/LICENSE
+ sha256sums = c2bc693a3871eb23464bc5706d4b1effcf0dfe8b8b5754b8182be065df0934e2
+ sha256sums = 3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986
+
+pkgname = hledger-flow-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbb0ea9c4ff9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: ravi0li <mail+aur at moritz dot pw>
+pkgname=hledger-flow-bin
+_gitname=${pkgname%-bin}
+pkgver=0.15.0
+pkgrel=1
+pkgdesc="An hledger/ledger-cli workflow focusing on automated statement import and classification"
+arch=('x86_64')
+url="https://github.com/apauley/hledger-flow"
+license=('GPL')
+_github_release_commit_hash="2b025fe"
+_github_release_file_name="hledger-flow_Linux_x86_64_v${pkgver}_${_github_release_commit_hash}"
+source=("https://github.com/apauley/${_gitname}/releases/download/v${pkgver}/${_github_release_file_name}.tar.gz"
+ "https://raw.githubusercontent.com/apauley/${_gitname}/master/LICENSE")
+sha256sums=("c2bc693a3871eb23464bc5706d4b1effcf0dfe8b8b5754b8182be065df0934e2" "3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986")
+
+package() {
+ install -Dm 755 -t "${pkgdir}/usr/bin" "${srcdir}/${_github_release_file_name}/hledger-flow"
+ install -Dm 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${srcdir}/LICENSE"
+}