summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgesh2021-11-01 19:07:41 +0200
committergesh2021-11-01 19:07:41 +0200
commit24a13e7ff5004b1b02e06cee745d1974aee9537d (patch)
treeffc185dbacf09f0803c95dec642e247ece376462
parentcdae7c5abefa83890be0fd7d899c0f08d16382ae (diff)
downloadaur-24a13e7ff5004b1b02e06cee745d1974aee9537d.tar.gz
Remove upstreamed verbump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--ver-bump.patch10
3 files changed, 6 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 811ee8157187..d3590aaf1524 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hlint-static-git
pkgdesc = Haskell source code suggestions
- pkgver = 3.3.4.r34.g918d3b99
- pkgrel = 2
+ pkgver = 3.3.4.r39.g8e10b514
+ pkgrel = 1
url = https://github.com/ndmitchell/hlint
arch = x86_64
license = BSD
@@ -12,8 +12,6 @@ pkgbase = hlint-static-git
conflicts = hlint
conflicts = hlint-bin
source = hlint-static-git::git+https://github.com/ndmitchell/hlint
- source = ver-bump.patch
sha256sums = SKIP
- sha256sums = 9a90d8aa9ccbc7668a6891c260a9038748954525ce36a7bf3d77f6ca4b922f67
pkgname = hlint-static-git
diff --git a/PKGBUILD b/PKGBUILD
index 7c7eb5703645..e8d5173f4c24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Dino Morelli <dino@ui3.info>
pkgname=hlint-static-git
-pkgver=3.3.4.r34.g918d3b99
-pkgrel=2
+pkgver=3.3.4.r39.g8e10b514
+pkgrel=1
pkgdesc='Haskell source code suggestions'
arch=('x86_64')
url="https://github.com/ndmitchell/hlint"
@@ -12,20 +12,14 @@ makedepends=('git' 'stack')
depends=('gmp')
provides=('hlint')
conflicts=('hlint' 'hlint-bin')
-source=("${pkgname}::git+${url}" ver-bump.patch)
-sha256sums=('SKIP'
- '9a90d8aa9ccbc7668a6891c260a9038748954525ce36a7bf3d77f6ca4b922f67')
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$pkgname"
- patch --forward --strip=1 --input="${srcdir}/ver-bump.patch"
-}
-
check() {
cd "$pkgname"
diff --git a/ver-bump.patch b/ver-bump.patch
deleted file mode 100644
index 25f91e1938fe..000000000000
--- a/ver-bump.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/stack.yaml b/stack.yaml
-index 2c26208c..3ee992bc 100644
---- a/stack.yaml
-+++ b/stack.yaml
-@@ -1,4 +1,4 @@
--resolver: nightly-2021-02-06 # ghc-8.10.3
-+resolver: lts-18.14
- packages:
- - .
- extra-deps: