summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgesh2021-02-07 01:45:40 +0200
committergesh2021-02-07 01:45:40 +0200
commitd423aaceba0c7f429be5152ea29fcb2e57ac00a3 (patch)
tree75ff76bec3e86a2e5ff8a3d0e683e65f0364fc99
downloadaur-d423aaceba0c7f429be5152ea29fcb2e57ac00a3.tar.gz
Initial commit (standard git+stack template)
-rw-r--r--.SRCINFO16
-rw-r--r--.gitattributes1
-rw-r--r--PKGBUILD42
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fb63cc39fe0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hlint-static-git
+ pkgdesc = Haskell source code suggestions
+ pkgver = 3.2.7.r19.g3d3c82c6
+ pkgrel = 1
+ url = https://github.com/ndmitchell/hlint
+ arch = x86_64
+ license = BSD
+ depends = gmp
+ provides = hlint
+ conflicts = hlint
+ conflicts = hlint-bin
+ source = hlint-static-git::git+https://github.com/ndmitchell/hlint
+ sha256sums = SKIP
+
+pkgname = hlint-static-git
+
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..a4dab8edd10c
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+.SRCINFO binary
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad41c64d12a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Gesh <gesh@gesh.uni.cx>
+# Contributor: Dino Morelli <dino@ui3.info>
+
+pkgname=hlint-static-git
+pkgver=3.2.7.r19.g3d3c82c6
+pkgrel=1
+pkgdesc='Haskell source code suggestions'
+arch=('x86_64')
+url="https://github.com/ndmitchell/hlint"
+license=('BSD')
+depends=('git' 'stack' 'gmp')
+provides=('hlint')
+conflicts=('hlint' 'hlint-bin')
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+check() {
+ cd "$pkgname"
+
+ stack test
+}
+
+build() {
+ cd "$pkgname"
+
+ stack setup
+ stack build \
+ --install-ghc \
+ --ghc-options='-fdiagnostics-color=always' \
+ --fast
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ stack install --local-bin-path "$pkgdir/usr/bin"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}