summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:02:57 +0100
committerDaniel Peukert2024-01-28 00:02:57 +0100
commit2ebf99ebe13279fc29d3c6c294a5f7ea3d2ad76e (patch)
treefb01c692f7dba09679c9c5a7a968904a6a849496
parent3e7ad3f4c40f8b06e5ad7036654d694ee5dea0a4 (diff)
downloadaur-2ebf99ebe13279fc29d3c6c294a5f7ea3d2ad76e.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD4
3 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cbbbe8ee8df..a75f333e0491 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = hlsdl
license = MIT
depends = curl
depends = openssl
- source = hlsdl-0.27-2.tar.gz::https://github.com/selsta/hlsdl/archive/cbf4301a912a3c0bbb418bd92b861f390f9c519c.tar.gz
+ source = hlsdl-0.27.tar.gz::https://github.com/selsta/hlsdl/archive/cbf4301a912a3c0bbb418bd92b861f390f9c519c.tar.gz
sha512sums = 54b03ea793a08d409d7764ab9c7b40b7a925c2cce95dfd5efd701d45814f9824334d285641bb355f8d00d5f710aadf976d933428dd5c23f027190f8cc59ffc5a
pkgname = hlsdl
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index fcde176dd602..3099beb33f58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('x86_64' 'i486' 'i686' 'pentium4' 'armv7h' 'aarch64')
url="https://github.com/selsta/$pkgname"
license=('MIT')
depends=('curl' 'openssl')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$_commit.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$_commit.tar.gz")
sha512sums=('54b03ea793a08d409d7764ab9c7b40b7a925c2cce95dfd5efd701d45814f9824334d285641bb355f8d00d5f710aadf976d933428dd5c23f027190f8cc59ffc5a')
_sourcedirectory="$pkgname-$_commit"
@@ -23,5 +23,5 @@ build() {
package() {
cd "$srcdir/$_sourcedirectory/"
install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/MIT"
}