summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-06-25 22:44:54 +0000
committerDaniel Bermond2021-06-25 22:44:54 +0000
commitba2a470db3bf333f6e73eeaf5c28c8fa92ecaab4 (patch)
tree92be75e0d2b10f64547d4443896c8b35a31e7cba
parent2662322c0e5f04ee0c9074d7f3f4e6d0ac7c2e74 (diff)
downloadaur-ba2a470db3bf333f6e73eeaf5c28c8fa92ecaab4.tar.gz
Fix build
-rw-r--r--.SRCINFO5
-rw-r--r--010-hm-disable-werror.patch11
-rw-r--r--PKGBUILD10
3 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18d5ad4e7747..cfdc580ab2f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hm-git
pkgdesc = HEVC Test Model - the reference software for HEVC (git version)
- pkgver = 16.22.r2.g9ea3a3e9
+ pkgver = 16.23.r32.g6169f170
pkgrel = 1
url = https://hevc.hhi.fraunhofer.de/
arch = x86_64
@@ -16,7 +16,8 @@ pkgbase = hm-git
conflicts = hm-svn
replaces = hm-svn
source = git+https://vcgit.hhi.fraunhofer.de/jct-vc/HM.git
+ source = 010-hm-disable-werror.patch
sha256sums = SKIP
+ sha256sums = 26ed4fb40812ecfce04b1301dc159fb2a575ece22a3532fe991f72e0f4e9488a
pkgname = hm-git
-
diff --git a/010-hm-disable-werror.patch b/010-hm-disable-werror.patch
new file mode 100644
index 000000000000..d4d32982d331
--- /dev/null
+++ b/010-hm-disable-werror.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -68,7 +68,7 @@ endif()
+ # bb_enable_warnings( gcc -Wno-unused-variable )
+ # bb_enable_warnings( gcc-4.8 warnings-as-errors -Wno-unused-variable )
+ # for gcc 8.2:
+-bb_enable_warnings( gcc warnings-as-errors -Wno-sign-compare -Wno-class-memaccess)
++bb_enable_warnings( gcc -Wno-sign-compare -Wno-class-memaccess)
+
+ if( XCODE )
+ bb_enable_warnings( clang warnings-as-errors
diff --git a/PKGBUILD b/PKGBUILD
index 6ba42f751cd3..0de068ba40c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=hm-git
-pkgver=16.22.r2.g9ea3a3e9
+pkgver=16.23.r32.g6169f170
pkgrel=1
pkgdesc='HEVC Test Model - the reference software for HEVC (git version)'
arch=('x86_64')
@@ -12,10 +12,13 @@ makedepends=('git' 'cmake' 'lsb-release' 'openmp')
provides=('hm' 'hm-svn')
conflicts=('hm' 'hm-svn')
replaces=('hm-svn')
-source=('git+https://vcgit.hhi.fraunhofer.de/jct-vc/HM.git')
-sha256sums=('SKIP')
+source=('git+https://vcgit.hhi.fraunhofer.de/jct-vc/HM.git'
+ '010-hm-disable-werror.patch')
+sha256sums=('SKIP'
+ '26ed4fb40812ecfce04b1301dc159fb2a575ece22a3532fe991f72e0f4e9488a')
prepare() {
+ patch -d HM -Np1 -i "${srcdir}/010-hm-disable-werror.patch"
cp -a HM HM-highbit
}
@@ -51,7 +54,6 @@ package() {
install -D -m755 "HM-highbit/bin/${_file}" "${pkgdir}/usr/bin/${_file/Static/HighBitDepthStatic}"
done < <(find HM-highbit/bin -maxdepth 1 -type f -executable -print0 | sed -z 's|HM\-highbit/bin||')
- install -D -m644 HM/README -t "${pkgdir}/usr/share/doc/${pkgname}"
install -D -m644 HM/doc/*.pdf -t "${pkgdir}/usr/share/doc/${pkgname}"
install -D -m644 HM/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}