summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-06-12 07:16:20 +0200
committerMichel Zou2019-06-12 07:16:20 +0200
commit60183b8775b4d6fd31ec884be8d980439184797e (patch)
tree2d477eb769ed8da7f64756555e4f542b0dfc49f2
parenta6be59589ad2eb1fd654ef1c1984f6d17d1a1cc6 (diff)
downloadaur-60183b8775b4d6fd31ec884be8d980439184797e.tar.gz
openblas_set_num_threads
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--set_num_threads.patch12
3 files changed, 17 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37bedd3334e1..398d6d27d380 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Mon May 29 20:09:58 UTC 2017
pkgbase = hmat-oss
pkgdesc = A hierarchical matrix C/C++ library
pkgver = 1.5.0
@@ -12,7 +10,9 @@ pkgbase = hmat-oss
depends = cblas
depends = lapack
source = https://github.com/jeromerobert/hmat-oss/archive/1.5.0.tar.gz
+ source = set_num_threads.patch
sha1sums = ea50bc4ee9eabd42fb81757c5549a2e592a4a434
+ sha1sums = SKIP
pkgname = hmat-oss
diff --git a/PKGBUILD b/PKGBUILD
index 3d04db589461..28e774771194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,13 @@ arch=('i686' 'x86_64')
url="https://github.com/jeromerobert/hmat-oss"
depends=('cblas' 'lapack')
makedepends=('cmake')
-source=("https://github.com/jeromerobert/hmat-oss/archive/${pkgver}.tar.gz")
-sha1sums=('ea50bc4ee9eabd42fb81757c5549a2e592a4a434')
+source=("https://github.com/jeromerobert/hmat-oss/archive/${pkgver}.tar.gz" set_num_threads.patch)
+sha1sums=('ea50bc4ee9eabd42fb81757c5549a2e592a4a434' SKIP)
prepare() {
cd $pkgname-$pkgver
sed -i "s|\-Werror||g" CMakeLists.txt
+ patch -p1 -i "$srcdir"/set_num_threads.patch
}
diff --git a/set_num_threads.patch b/set_num_threads.patch
new file mode 100644
index 000000000000..861267e592ec
--- /dev/null
+++ b/set_num_threads.patch
@@ -0,0 +1,12 @@
+diff --git a/src/disable_threading.cpp b/src/disable_threading.cpp
+index e3be7ff..94c645a 100644
+--- a/src/disable_threading.cpp
++++ b/src/disable_threading.cpp
+@@ -36,6 +36,7 @@
+ extern "C" {
+ // This function is private in openblas
+ int goto_get_num_procs(void);
++void openblas_set_num_threads(int num_threads);
+ }
+ #endif
+