summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorso1ar2021-12-18 17:48:51 +0800
committerso1ar2021-12-18 17:48:51 +0800
commit3c25a771f52da81f1566f4b0a62b7509edea227b (patch)
tree41b9b1f5b7eea118ed4e1c36cc3f4f94c7820e26
parent129a7c94a8c0db6e455537de0bbd9311d912a319 (diff)
downloadaur-3c25a771f52da81f1566f4b0a62b7509edea227b.tar.gz
update 3.5.213 && add LICENSE
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bb48efb507b..f9b089126701 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hmcl-bin
pkgdesc = A Minecraft Launcher which is multi-functional, cross-platform and popular.
- pkgver = 3.4.212
+ pkgver = 3.5.213
pkgrel = 1
url = https://github.com/huanghongxun/HMCL
arch = any
@@ -8,14 +8,16 @@ pkgbase = hmcl-bin
depends = java8-openjfx
provides = hmcl
conflicts = hmcl
- noextract = hmcl-bin-3.4.212-1.jar
+ noextract = hmcl-bin-3.5.213-1.jar
source = hmcl.desktop
source = hmcl-launch-script
source = craft_table.png
- source = hmcl-bin-3.4.212-1.jar::https://cdn.jsdelivr.net/npm/hmcl-update@3.4.212/HMCL-3.4.212.zip
+ source = https://raw.githubusercontent.com/huanghongxun/HMCL/javafx/LICENSE
+ source = hmcl-bin-3.5.213-1.jar::https://ci.huangyuhui.net/job/HMCL/lastSuccessfulBuild/artifact/HMCL/build/libs/HMCL-3.5.213.jar
sha1sums = 613a2483883028a52b369c27c1468fc8d31e2d5e
sha1sums = ff8a9141b115ea7788111ce28cc462c8fd46c471
sha1sums = 635509ef81b82837fcd1f7d4b24a7d44241559c2
- sha1sums = a8433b7a09639a294c3c311771edc9e335989494
+ sha1sums = 31a3d460bb3c7d98845187c716a30db81c44b615
+ sha1sums = 6942b8c6d33b78506f85c4a4eccee32db1606acd
pkgname = hmcl-bin
diff --git a/PKGBUILD b/PKGBUILD
index d26755eb8a31..bd1fb86284a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: So1ar <so1ar114514@gmail.com>
pkgname=hmcl-bin
-pkgver=3.4.212
+pkgver=3.5.213
pkgrel=1
pkgdesc="A Minecraft Launcher which is multi-functional, cross-platform and popular."
arch=('any')
@@ -14,11 +14,13 @@ conflicts=('hmcl')
source=("hmcl.desktop"
"hmcl-launch-script"
"craft_table.png"
- "${pkgname}-${pkgver}-${pkgrel}.jar::https://cdn.jsdelivr.net/npm/hmcl-update@${pkgver}/HMCL-${pkgver}.zip")
+ "https://raw.githubusercontent.com/huanghongxun/HMCL/javafx/LICENSE"
+ "${pkgname}-${pkgver}-${pkgrel}.jar::https://ci.huangyuhui.net/job/HMCL/lastSuccessfulBuild/artifact/HMCL/build/libs/HMCL-${pkgver}.jar")
sha1sums=('613a2483883028a52b369c27c1468fc8d31e2d5e'
'ff8a9141b115ea7788111ce28cc462c8fd46c471'
'635509ef81b82837fcd1f7d4b24a7d44241559c2'
- 'a8433b7a09639a294c3c311771edc9e335989494')
+ '31a3d460bb3c7d98845187c716a30db81c44b615'
+ '6942b8c6d33b78506f85c4a4eccee32db1606acd')
noextract=("${pkgname}-${pkgver}-${pkgrel}.jar")
@@ -27,4 +29,5 @@ package() {
install -Dm644 "hmcl.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -Dm644 "${pkgname}-${pkgver}-${pkgrel}.jar" "${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar"
install -Dm644 "craft_table.png" "${pkgdir}/usr/share/icons/hicolor/48x48/apps/${pkgname}.png"
+ install -Dm644 "LICENSE" "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}