summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-06-12 12:07:18 +0100
committermschubert2015-06-12 12:07:18 +0100
commit4d730d01699175181f6717fd799cc69a7e2e9d77 (patch)
treeae95b2cd81da146cb210bea3cf6461d4b49680a9
downloadaur-4d730d01699175181f6717fd799cc69a7e2e9d77.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27685375bbaa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hmmer
+ pkgdesc = Profile hidden Markov models (profile HMMs) for database searching using statistical descriptions of a sequence family's consensus
+ pkgver = 3.1b1
+ pkgrel = 2
+ url = http://hmmer.janelia.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = http://selab.janelia.org/software/hmmer3/3.1b1/hmmer-3.1b1.tar.gz
+ md5sums = e81b689fe1dd7625cff84c08cbead1fc
+
+pkgname = hmmer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e13563e71f2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+
+pkgname=hmmer
+pkgver=3.1b1
+pkgrel=2
+pkgdesc="Profile hidden Markov models (profile HMMs) for database searching using statistical descriptions of a sequence family's consensus"
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://hmmer.janelia.org/'
+depends=('glibc')
+source=("http://selab.janelia.org/software/hmmer3/$pkgver/hmmer-$pkgver.tar.gz")
+md5sums=('e81b689fe1dd7625cff84c08cbead1fc')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make prefix="$pkgdir/usr" install
+}
+